View Full Version : Already problems...



Cream Pie
08-17-2011, 08:35 PM
Just bought 272 w/ 502 with, seemingly true, fresh build ( 6 hours showing on tach ) - I personally judge engine time by the ease of hose removal. These seem to come off easily.

Anyway.... Put a few hours on her, wanting to see what pops up on used boat. There seems to be a fuel issue. It falls off after a few min ( one or two ) of like 95% throttle. There is also a squeal like sound after these short runs. Kinda like a pulley chirp - like a dying bird, lol.


Then, yesterday, it won't stay running. It's starts and shuts itself off within 10 seconds. Now it will only turn over. Come to discovery the mechanical fuel pump, lift pump crapped out. Then to disassemble and
find " finger " on same pump wiped out, like the metal is smeared. Come
to discovery there is / was NO oil in raw water pump cam area that this pump runs off / mounts too.

Got that ordered as no one stocks anything in Orlando, Fl.

Question : Any thing else to check before simple fixes become projects
and have to wait for parts. I have had many a boat bigger and smaller etc. But our first Baja. We are still all about it just odd that the pump was completely dry and yet it ran for 5 hours plus over four uses.

will22
08-18-2011, 10:51 AM
had the same thing happen to my 502mag - that gasket fails and lets raw fuel in there instead of oil so then the cam is metal to metal with no lube and eventually wears a groove in the arm....i replaced the mech feul pump assembly and its never hick-uped since. good luck and hope that solves it.

Bajapred
08-18-2011, 05:53 PM
Pulley chirp thing could be a faulty circulating pump...check cir pump weep hole behind pulley...I have even seen them squirt a stream of water after getting up to about 2700 rpm. You probably already know this but..the fuel pump does not use regular oil, i believe it uses same kind of oil that is in your bravo drives..just makin sure! good luck!

Cream Pie
08-18-2011, 07:26 PM
Yes. Thank you both. Replaced the fuel pump and the complete raw water pump assembly. Runs like a beat dog now. Better idle, as if the metal on metal action was dragging it down at idle. Also seemingly no more bird chirping sound when returning to slow rpm or idle after cruising a bit at speed.

Thanks again.