If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Follow us on Facebook Follow us on Twitter
Results 1 to 3 of 3

Thread: Lose of power

  1. #1
    Join Date
    Jun 2006

    Lose of power

    I have a 1990 454 Mercrusier. I start losing RPM's, power and speed after running hard for about 5 to 8 minutes. Once I reduce my speed to an idle for about 2 minutes and can get back up to max speed until this cycle (lose of power) starts over again . Any ideas why this is happening? Could it be that I have a 165F thermostat and not the 143F thermostat

  2. #2
    Registered ratman's Avatar
    My Boats:
    michelob light scarab, sold, sailor now
    Join Date
    Oct 2004
    medellin colombia, pablo escobar's lil town

    Re: Lose of power

    you might be lossing power cuz your running the engine out of petrol

  3. #3
    AT Cult Member #3 VIP Member R Addiction's Avatar
    My Boats:
    '99 Active Thunder Tantrum
    Join Date
    Oct 2000

    Re: Lose of power

    Sounds like fuel related. Have you changed the filter lately?

Similar Threads

  1. Replies: 4
    Last Post: 11-28-2006, 07:01 PM
  2. Replies: 23
    Last Post: 06-21-2006, 04:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
All times are GMT -5. The time now is 06:03 AM.
Powered by vBulletin® Version 4.2.0
Copyright © 2016 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
Original Poster In Postbit provided by Original Poster In Postbit v1.0.0 (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2011 OffShoreOnly. All rights reserved.