If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Follow us on Facebook Follow us on Twitter
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39
  1. #1
    Rob VIP Member Strip Poker 388's Avatar
    My Boats:
    Hustler 388
    Join Date
    Aug 2001

    Question 4 Engine Coupler Failures, Why???

    I have a friend that has a 2001 Cig with stock 500efis. He said he got caught up on some brush,tree limbs something like that at TickFaw poker run and tried to get on plane and spun out the hubs.No prop damage.I wasn't on the boat so I really dont know what happened. He had 2 new ones put in and supposedly had the engines aligned Now after about 5 hours of running this past weekend they spun out again. Again I wasnt in the boat so I dont know what he was doing? He is New to powerboats and is 67 years old.I have told him about not stabbing it getting on plane and not jumping it out of the water.After they cool off it will get back on plane but slips after about 5 miles.

    My question is can jumping out of the water or really leaning on it getting on plane cause this? I know of a lot of people that abuse their stuff and dont have this prob, Or even have 900plus HP going thru them.

    The only other thing I am thinking is engine alignment is off?

    Any suggestions?

    Thanks for any help
    Attached Images Attached Images

    Boost makes up for Cubic Inchs

  2. #2
    Platinum Member Platinum Member tomtbone1993's Avatar
    My Boats:
    Join Date
    Sep 2003
    he was a nice guy, that sucks about his luck
    Last edited by tomtbone1993; 05-29-2007 at 11:39 PM.

  3. #3
    Gold Member Gold Member phragle's Avatar
    My Boats:
    22 Avanti, 25 Nova, 2 turtle doves and a partridge in a pear tree,SBYC
    Join Date
    Apr 2006
    Toledo Oh
    a soft transom can eat couplers..but the boats not that guess is alignment..any vibrations?? sticky u joint etc???
    please read the fine print

  4. #4
    Platinum Member Platinum Member articfriends's Avatar
    My Boats:
    EX 99 MPH 272 Baja owner, 1999 Scarab 33 AVS NOW
    Join Date
    Jun 2004
    I'm not sure what he's running over but I ran my coupler (hp/xr style though) behind 750 hp for 2 years and 950 hp for 1 full season and part of a 2nd until I switched to the stellings box last year and it still looks like new,I'm getting ready to run it some more. There is something else going on here he needs to figure out,Smitty

  5. #5
    Registered racesdad's Avatar
    My Boats:
    07 368 SKATER and shes bad
    Join Date
    Mar 2002
    racing capitol of the world
    make sure the the drives are aligned and if the coupler has been replaced, make sure the correct one was used. something is not right

  6. #6
    Charter Member # 55 Charter Member Griff's Avatar
    My Boats:
    ..........32........... Active Thunder
    Join Date
    Oct 2000
    I would also replace with the HD couplers used on the 575sci and up-#21 in the diagram.

  7. #7
    Off the Radar Platinum Member Linster's Avatar
    My Boats:
    39 Cigarette Unlimited, 24 South Bay Tri-toon, & Seadoo GTX
    Join Date
    May 2001
    Short Pump or Colonial Beach, VA
    With offshore mounts, alignment is not an adjustment. It has to be an alignment issue. I had to redrill all my Aluminum mounts. I used HD couplers as suggested. They are not forgiving for mis-alignment. Also check the yoke shaft to make sure that the splines are flat. Tell us what you find.

  8. #8
    Driver-441 Racer TeamSaris's Avatar
    My Boats:
    32 Cobra Raceboat, 27 Avanti Raceboat 27 Kryptonite Raceboat
    Join Date
    Aug 2004
    Lake George
    World & National Champions

  9. #9
    OSO is offline
    Super Moderator VIP Member OSO's Avatar
    My Boats:
    I like them all!!
    Join Date
    Oct 2003
    spun out the hubs? are they metal?

    I had a problem last year after getting a crab trap line caught around a prop. It acted very much like a coupler problem and ended up being a slightly worn clutch in the drive. The problem would come and go.

    good luck

  10. #10
    RHC is offline
    Registered RHC's Avatar
    Join Date
    Oct 2002
    Sandusky Bay
    Two thought's,,,,, Alignment and buy the latest HD Coupler ,, check the input drive shaft for sharp edge'S ,,, they will eat the spline then run crooked


Page 1 of 4 123 ... LastLast

Similar Threads

  1. Engine Coupler
    By Boomer35 in forum General Boating Discussion
    Replies: 5
    Last Post: 10-21-2008, 11:46 AM
  2. engine coupler
    By bajabob in forum General Q & A
    Replies: 4
    Last Post: 04-28-2008, 08:04 AM
  3. Engine coupler
    By mopower in forum General Q & A
    Replies: 10
    Last Post: 06-25-2005, 10:09 PM
  4. Engine Failures Thanks to Wiseco
    By Goodfella in forum General Boating Discussion
    Replies: 16
    Last Post: 01-20-2003, 07:27 PM
  5. Engine Coupler
    By BAD-HABIT in forum General Q & A
    Replies: 6
    Last Post: 03-19-2002, 08:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
All times are GMT -5. The time now is 06:51 PM.
Powered by vBulletin® Version 4.2.0
Copyright © 2016 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
Original Poster In Postbit provided by Original Poster In Postbit v1.0.0 (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2011 OffShoreOnly. All rights reserved.