If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Follow us on Facebook Follow us on Twitter
Results 1 to 3 of 3
  1. #1
    My Boats:
    2007 Donzi 38ZR
    Join Date
    Jan 2009
    Stroudsburg, PA & Lighthouse Point, FL

    502mpi temp @ WOT

    Whats the temp supposed to be at wot? It runs around 160-170 until WOT, around 190....too hot? I back flushed everything and changed the impellar. 2000 502mpi

  2. #2
    My Boats:
    2011 Invisible Canoe
    Join Date
    May 2005
    Nashville, Tennessee
    mine was having similar problems when i bought it - prior owner had an impellar go out and just replaced it with a new one and didnt clean the little rubber frags out of the system....either the water cooler or the oil cooler - one has a honey comb grill to prevent stuff from passing....i'd suggest checking both for visible pieces...i had to take a screwdriver to get some of them to break free. been running 160 since then under most conditions. good luck, hope this helps and im not repeating things youve done already.

  3. #3
    Charter Member # 55 Charter Member Griff's Avatar
    My Boats:
    ..........32........... Active Thunder
    Join Date
    Oct 2000
    My 2000 502mpi's never go above 180*

    160-165* at cruise speeds and about 170-175* at WOT.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
All times are GMT -5. The time now is 07:54 PM.
Powered by vBulletin® Version 4.2.0
Copyright © 2016 vBulletin Solutions, Inc. All rights reserved.
Search Engine Optimization by vBSEO 3.6.1
Original Poster In Postbit provided by Original Poster In Postbit v1.0.0 (Free) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
Copyright 2011 OffShoreOnly. All rights reserved.