Check to see if your active scripting is enabled. Go to tools then internet options then security then internet zone and click on the box for custom level. Under scripting, you should have active scripting enabled. If you have disabled it to prevent getting popup adds like i had, this site wont work correctly.