Like Tree0Likes

Trim and Tabs "popping" through the speakers.

Reply
Old 05-14-2007, 01:02 PM
  #11
Charter Member #232
Charter Member
 
Audiofn's Avatar
 
Join Date: Oct 2000
Location: Carlisle, MA USA
My Boats: 1979 Formula 302, 99 Formula 353, 81 Donzi 18 2+3 with 454
Posts: 18,379
Default

Make sure your ground for the amp and the radio go directly to the battery and are grounded together. If you want drop me a line and I will help ya out. Could be a bad RCA wire as well. Seen that a few times. You should be carefull as you can blow the amp and speakers if you get a bad enough pop.

Jon
__________________
Put your best foot forward!
Audiofn is offline  
Reply With Quote
Old 05-14-2007, 01:40 PM
  #12
Registered
Gold Member
Thread Starter
 
DoTheMath's Avatar
 
Join Date: May 2002
Location: Ma. / Lake Winni., NH
Posts: 1,803
Default

Thanks Jon, I have done several systems in the past (myself from scratch) and never had an issue - but somone else did this one and, well... And if I do blow the amp, no worries as I have better stuff I may replace it with anyway, so we'll see. But thanks for the offer - if I get stuck your phone might be ringin'!
DoTheMath is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
totalrex
General Q & A
9
02-21-2016 06:08 PM
onesickpantera
General Q & A
1
08-05-2007 06:25 PM
JasonSmith
Baja
5
06-23-2005 03:08 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:17 PM.


Copyright 2011 OffShoreOnly. All rights reserved.