Like Tree0Likes

livorsi gps tattle tale problems-help?

Reply
Old 06-22-2007, 12:06 PM
  #11
Platinum Member
Platinum Member
 
Join Date: Dec 2002
Location: Dallas, TX
My Boats: 1987 Scarab Panther
Posts: 2,118
Default

Hey TP,
Is this an ongoing Livorsi GPS defect? Is it an owner operational or installation error? Livorisi is a player in the marine industry and someone should explain to the current customers what is happening to these GPS's and what buyers can expect going forward. Is there a direct contact at Livorisi to call for service?
What is the expected life of a Livorsi GPS? As a Livorsi dealer, maybe you could guide the OSO members.
Thanks,
Ben
BenPerfected is online now  
Reply With Quote
Old 06-22-2007, 12:11 PM
  #12
Registered
 
Join Date: Oct 2000
Location: Fells Point MD
My Boats: 1999 Spectre 36
Posts: 532
Default

Mine worked fine for the last two years and only started this when I first used the boat this year. Its not an installation or use issue.



Shawn
shawn is offline  
Reply With Quote
Old 06-22-2007, 01:09 PM
  #13
Charter Member
 
Join Date: Apr 2001
Location: Albuquerque, NM
My Boats: Baja 322 - Twin 540's
Posts: 606
Default

Quote:
Originally Posted by BenPerfected View Post
Hey TP,
Is this an ongoing Livorsi GPS defect? Is it an owner operational or installation error? Livorisi is a player in the marine industry and someone should explain to the current customers what is happening to these GPS's and what buyers can expect going forward. Is there a direct contact at Livorisi to call for service?
What is the expected life of a Livorsi GPS? As a Livorsi dealer, maybe you could guide the OSO members.
Thanks,
Ben
Ben,

No there are not any problems or defects with the Livorsi units as far as I know. All Livorsi products do carry a one year warranty and you can work through Livorsi direct or go through the dealer or boat manufacturer that you bought your unit from.

You can reach Livorsi Marine at 847 548-5900. I know this is going to sound dumb, but please make sure that it is a Livorsi Marine unit prior to calling them, not a Gaffrig Performance, Autometer or some other brand...it will save everyone sometime.

If your unit is still under warranty I would suggest calling Livorsi Marine direct to have it replaced; once again it will save a little time.

I would be more than happy to assist in anyway that I can, feel free to contact me directly at 505 345-3760 or [email protected]

Thanks,
Don Baca
tpmarine.com is offline  
Reply With Quote
Old 06-24-2007, 07:52 PM
  #14
Registered
 
Join Date: Aug 2006
Location: Boca Raton, Florida
My Boats: 26 Scarab
Posts: 57
Default

Quote:
Originally Posted by shawn View Post
Mine worked fine for the last two years and only started this when I first used the boat this year. Its not an installation or use issue.



Shawn
Same here.
Hot4Teacher is offline  
Reply With Quote
Old 07-13-2007, 05:02 PM
  #15
Registered
 
Join Date: Oct 2000
Location: Fells Point MD
My Boats: 1999 Spectre 36
Posts: 532
Default

Well boys and girls, there is now more to my story.

I pulled the unit and sent it to Livorsi, they got it on July 3rd. They took off for the fourth of July, OK, no big deal.
They fixed and shipped it back on July 5th.
All at no charge.
I put it back in and today was the first chance I had to run the boat and it works like a champ.

Its nice to give credit where its due and in this case there are BIG words of "JOB WELL DONE" from me.

Livorsi is obviously a first class operation.

Thanks.
Shawn
shawn is offline  
Reply With Quote
Old 07-13-2007, 05:07 PM
  #16
Registered
 
sakoutis3's Avatar
 
Join Date: Jul 2005
Location: Colts Neck,NJ
My Boats: 2002 Outer Limits 51'
Posts: 2,149
Default

Mayby your boat is just slow.
sakoutis3 is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Velocity Vector
General Boating Discussion
5
04-02-2012 04:35 PM
Yellow_ICC_OK
General Q & A
0
09-04-2008 11:58 AM
carcommander
General Q & A
4
04-24-2008 08:12 PM
tgersx
General Q & A
3
06-09-2007 10:27 AM
tgersx
General Boating Discussion
1
06-08-2007 06:18 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:37 PM.


Copyright 2011 OffShoreOnly. All rights reserved.