Like Tree0Likes

Big cubic inches or supercharger?

Reply
Old 07-27-2007, 01:17 PM
  #31
Registered
 
StraightJacket's Avatar
 
Join Date: May 2006
Location: In a box, s. side of chi town
My Boats: 38 Fountain Fever with #4's, ok so it really 35
Posts: 793
Default

N/A's from this camp .. 540 std deck 730 hp 690 ft lbs of torque, put together right very dependable .
StraightJacket is offline  
Reply With Quote
Old 07-27-2007, 01:17 PM
  #32
Registered
Thread Starter
 
Join Date: Apr 2006
Location: Grand Lake (E-Dock Junior Varsity)
My Boats: 24 Skater, 292 SR-1 Formula, 382 Fastech, 41 PC
Posts: 3,017
Default

the 622ci motors were from 1800runsnew.com
Anyone have any experience with them? What else will be needed for a swap if they are "fully dressed"? If i purchased these, are they an easy swap or is this something thats would need to be custom.
waterboy222 is offline  
Reply With Quote
Old 07-27-2007, 03:26 PM
  #33
Registered
Platinum Member
 
Join Date: Jun 2006
Location: Lake Conroe, TX.
My Boats: 39' Sea Ray, 38' Nortech, 18' Taylor SJ
Posts: 14,916
Default

Quote:
Originally Posted by waterboy222 View Post
the 622ci motors were from 1800runsnew.com
Anyone have any experience with them? What else will be needed for a swap if they are "fully dressed"? If i purchased these, are they an easy swap or is this something thats would need to be custom.

Make sure you can get fuel to them.
Tall deck motors possible have an exhaust issue due to deck height. Most of the time not though.
Also check new overall height because f new intake, different carb etc.

That will get you started. THe rest you will just have to figure out.
jeff1000man is offline  
Reply With Quote
Old 07-27-2007, 04:03 PM
  #34
Rob
VIP Member
Trade Score: (6)
 
Strip Poker 388's Avatar
 
Join Date: Aug 2001
Location: Madison,Mississippi
My Boats: Hustler 388
Posts: 21,567
Superchargers
Attached Thumbnails
Big cubic inches or supercharger?-outdrive5106015mediumnl0.jpg  
__________________
.

The Only Time You Have To Much Ammo Is When Your Swimming Or On Fire.
Strip Poker 388 is offline  
Reply With Quote
Old 07-27-2007, 04:29 PM
  #35
Registered
 
Join Date: Aug 2005
Location: Las Vegas
My Boats: 1999 270S Hallett
Posts: 207
Default

I like my 540 built for a 700-1000 hp. All the good lower end stuff, steel heads(salt water), small whipple(side mount 2.3). dyno'n this weekend. should be around 800 +. throw on a larger whipple say 3.3 or a set of whipples and have to do NOTHING to the engine. then you have over 1000 hp. its all about the long block. OVER build the long block = HUGE OIL COOLER and put whatever you want on the top. Oh by the way, its fuel injected..

I'll post more info if anyone want it on a 502 build up. will be a 540 SIDE MOUNTED WHIPPLE. I don't think you'll see many of those around. This set up is for us guys who don't have a deep engine well and don't have a scoop.. going to look sweet....

Last edited by VegasHallett; 07-27-2007 at 04:35 PM.
VegasHallett is offline  
Reply With Quote
Old 07-27-2007, 04:35 PM
  #36
Registered
 
Wardey's Avatar
 
Join Date: Nov 2001
Location: Palm Harbor, FL
My Boats: 2005 Extreme 29
Posts: 3,959
Default

Carolina Racing Engines did my 572's cu in but I only have Tyler do my motors now. Link is on my signature at the bottom. Dave
Wardey is offline  
Reply With Quote
Old 07-29-2007, 09:46 AM
  #37
Registered
 
Join Date: Aug 2005
Location: South FL
My Boats: Big Ole 42' Cruiser w Arnies.
Posts: 292
Default

Wardey - fellow Floridian here - Tyler who?
Swamplizard is offline  
Reply With Quote
Old 07-29-2007, 10:03 AM
  #38
Geronimo36
Gold Member
 
Panther's Avatar
 
Join Date: Sep 2002
Location: Elkton, MD
My Boats: 36' Apache Warrior / 22' Apache Scout
Posts: 11,838
Default

Quote:
Originally Posted by Gary864 View Post
I have had blowersin a 32 Sunsation that was tough to beat but I have a long idle in and out of my canal and the blowers seemed to load up. This might be fixed with fuel injection but I am no expert.
sounds like a setup issue...

I'm running 580" blower motors (838 hp - low boost) and have no idle issues what so ever. If it was loading up it probably wasn't set up right.

Last edited by Panther; 07-29-2007 at 10:07 AM.
Panther is offline  
Reply With Quote
Old 07-29-2007, 01:10 PM
  #39
Registered
 
Wardey's Avatar
 
Join Date: Nov 2001
Location: Palm Harbor, FL
My Boats: 2005 Extreme 29
Posts: 3,959
Default

Quote:
Originally Posted by Swamplizard View Post
Wardey - fellow Floridian here - Tyler who?
Tyler Crockett with Tyler Crockett Racing Engines. One of the best in the business and very trustworthy. Link is at the bottom. Dave
Wardey is offline  
Reply With Quote
Old 07-29-2007, 02:54 PM
  #40
Registered
Platinum Member
 
Join Date: Jun 2006
Location: Lake Conroe, TX.
My Boats: 39' Sea Ray, 38' Nortech, 18' Taylor SJ
Posts: 14,916
Default

Quote:
Originally Posted by Panther View Post
sounds like a setup issue...

I'm running 580" blower motors (838 hp - low boost) and have no idle issues what so ever. If it was loading up it probably wasn't set up right.
Running to rich down low, but probably need it high.

A freind of mine has same problem. Rotate one in and out of neutral and keep the Rpm's up to clear them out.
jeff1000man is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bcfountain
Fountain
9
08-14-2007 03:17 PM
SinkorSwim
General Q & A
28
12-11-2003 12:38 PM
Ratchet
General Boating Discussion
19
11-16-2002 05:20 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:36 PM.


Copyright 2011 OffShoreOnly. All rights reserved.