Like Tree0Likes

1996 7.4 mpi clicking sounds

Reply
Old 04-19-2009, 12:21 PM
  #1
Registered
Thread Starter
 
Join Date: Apr 2009
Posts: 110
Default 1996 7.4 mpi clicking sounds

when i try to start the motor i only get a clicking sound comming out of the box right side of the motor under the reset button it sounds like a low battery click at the starter but its not the batteries are full charge im wondering did i hook up the starter wrong , and when i try to put a screw driver to try to jump the starter to make it work , nothing happens , and their is juice to the starter , i hooked the battery wire and the oranger and red wire to the starter and the yellow and red to the other small termial, can anyone help me pz thankyiou james
jimmie is offline  
Reply With Quote
Old 04-19-2009, 08:59 PM
  #2
Registered
 
Join Date: Mar 2009
Posts: 496
Default

Quote:
Originally Posted by jimmie View Post
when i try to start the motor i only get a clicking sound comming out of the box right side of the motor under the reset button it sounds like a low battery click at the starter but its not the batteries are full charge im wondering did i hook up the starter wrong , and when i try to put a screw driver to try to jump the starter to make it work , nothing happens , and their is juice to the starter , i hooked the battery wire and the oranger and red wire to the starter and the yellow and red to the other small termial, can anyone help me pz thankyiou james
Try this one more time, hook up agood size wire from the batterie power and touch it to the yellow/red little wire post if the engine will not turn over then the starter is bad or stuck.
Boat Tech is offline  
Reply With Quote
Old 04-20-2009, 11:19 AM
  #3
Registered User
 
Shanghied Again's Avatar
 
Join Date: Feb 2002
Location: Toms River NJ
My Boats: Shanghied! 2004 Donzi 33 ZX
Posts: 1,422
Default

If its a Merc make sure the starter fuse isn't blown. Its hooked up on the starter and depending on the amp can be black or white in color.
Shanghied Again is offline  
Reply With Quote
Old 04-20-2009, 11:27 AM
  #4
Pit
Registered
 
Pit's Avatar
 
Join Date: Apr 2004
Location: THE NORTH EAST...
Posts: 139
Default

Could be a bad ground also.
Pit is offline  
Reply With Quote
Old 04-20-2009, 06:46 PM
  #5
Registered
 
Join Date: Mar 2009
Posts: 496
Default

Quote:
Originally Posted by Pit View Post
Could be a bad ground also.
True this boat seams to have a lot of wires unhooked looking at all his past post.
Boat Tech is offline  
Reply With Quote
Old 04-20-2009, 07:53 PM
  #6
Registered
Thread Starter
 
Join Date: Apr 2009
Posts: 110
Default Clicking 7.4 mpi

yes i bought the motor off the internet was suppost to be complete but wasnt i had to spend another 2000 to get it complete so its been a night mare,but with youalls help its been much easier
jimmie is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:42 AM.


Copyright 2011 OffShoreOnly. All rights reserved.