Like Tree0Likes

525 efi wiring to analogue gauges

Reply
Old 05-15-2009, 09:25 PM
  #1
Registered
Thread Starter
 
Join Date: Aug 2004
Location: Kentucky
My Boats: Looking for ?
Posts: 94
Default 525 efi wiring to analogue gauges

I need some help. I am installing a 525 merc . I have analogue gauges in my talon and of course the new merc is digital. I have called merc and bought a conversion box No joy. Now I hear it will take a new wiring harness. If that is what will do it so be it but that is a chunk of change. I know out there this has been done before, so has anyone put a racing 525 efi into a boat that has analogue gauges? I am st a stand still. The engine is in I am buying a water pressure limiter from merc as my pickup is a clam shell on the bottom of the boat and reaches over 35 lbs. pressure at speed. I am thinking of putting a strainer in, and a bigger oil cooler. I want this boat to be as bullet proof as it can. The out drive is an IMCO extreme with a 1.29 ratio. Hydraulic steering (Imco).

Any and all guidance will be appreciated
Attached Thumbnails
525 efi wiring to analogue gauges-jt11.jpg  
orthos1 is offline  
Reply With Quote
Old 05-15-2009, 11:27 PM
  #2
Platinum Member
Platinum Member
 
Join Date: Jan 2003
Location: Brookfield, Wi.
My Boats: 33 Active Thunder
Posts: 934
Default

I did the same swap about 3 years ago. I was a little confused at first but got the AGI box that allowed me to use my existing analog gauges. I also bought a new 14 pin wiring harness but it wasn't to costly. As far as the water pressure, I'm drawing mine thru the DWP on a XT outdrive and see between 35-40 psi which from my understanding is typical and supposedly not a problem according to Mercury Racing. I was concerned about the pressure also, but I think because it's a closed cooling system, the higher pressure is not as critical (right?). I doubt that you'll need a larger oil cooler than Mercury designed for the motor. I've been extremely happy with the motor and haven't had an ounce of trouble with it. By the way, I've also been a fan of Talons, especially the 22 and 25 models. What was the previous power you were running? Steve
509 SC is offline  
Reply With Quote
Old 05-16-2009, 04:46 PM
  #3
Registered
 
BRUCE SEROFF's Avatar
 
Join Date: Aug 2001
Location: Edison, NJ, USA
Posts: 6,337
Default

Im in the process of doing the same thing. Just got the AGI. ordered the harness from BAM around 60 bucks. Should have it this week. I think the entire kit with key switch , warning horn and all the trimmings is around 500 bucks. But In a race boat, I dont need all that.

This is the kit they told me to buy. this is the entire rigging kit.
But if you just want to hook up the AGI, I dont think you need everything.

http://www.mercruiserparts.com/Show_...ngle+Engine%29

The CAN harness I ordered is 879968T20. I hope it works.

Any Input is greatly appreciated

Last edited by BRUCE SEROFF; 05-16-2009 at 04:49 PM.
BRUCE SEROFF is offline  
Reply With Quote
Old 05-16-2009, 06:38 PM
  #4
Registered
Thread Starter
 
Join Date: Aug 2004
Location: Kentucky
My Boats: Looking for ?
Posts: 94
Default

Steve

I was running a 502 punched to 510 BDS Blower two holley dominator flowing 1150 each. Dyno 870 hp lots of torque. The out drive was a bravo one that was beefed up by the bravo shop (i ate two up) running a 34 pitch spinnelli. I had no hole shot but would make you cry between 50 and 100. top speed was radar @124mph running on the edge.

Stu
Attached Thumbnails
525 efi wiring to analogue gauges-jt10sm.jpg   525 efi wiring to analogue gauges-jt8.jpg  
orthos1 is offline  
Reply With Quote
Old 05-16-2009, 06:42 PM
  #5
Registered
Thread Starter
 
Join Date: Aug 2004
Location: Kentucky
My Boats: Looking for ?
Posts: 94
Default

More Pics
Attached Thumbnails
525 efi wiring to analogue gauges-jt15.jpg   525 efi wiring to analogue gauges-jt9.jpg   525 efi wiring to analogue gauges-jt16.jpg  

orthos1 is offline  
Reply With Quote
Old 05-17-2009, 09:15 PM
  #6
Platinum Member
Platinum Member
 
Join Date: Jan 2003
Location: Brookfield, Wi.
My Boats: 33 Active Thunder
Posts: 934
Default

Stu, Are you going to the 525 for more reliability, or is there a Whipple in the future? Looks like you upgraded the front buckets, the original ones from Talon didn't look to comfortable! Steve
509 SC is offline  
Reply With Quote
Old 06-01-2009, 10:36 PM
  #7
Registered
Trade Score: (5)
 
Join Date: Oct 2005
Location: Clarkston, Michigan
My Boats: 22 Donzi Classic 525 EFI
Posts: 4,636
Default

Great info. I also swapped a 525 EFI in place of a 496 HO only to find that the gauges don't work and the up trim only works in trailer position. I will be calling Bam to see if they can hook me up with what I need.

One more question though, I was told that the 525 ECU must be programmed to tell it to run analog gauges instead of digital. Where can I get that done?
thirdchildhood is offline  
Reply With Quote
Old 06-01-2009, 10:46 PM
  #8
Registered
 
Join Date: Sep 2008
Location: LOTO
Posts: 1,200
Default

Quote:
Originally Posted by thirdchildhood View Post
Great info. I also swapped a 525 EFI in place of a 496 HO only to find that the gauges don't work and the up trim only works in trailer position. I will be calling Bam to see if they can hook me up with what I need.

One more question though, I was told that the 525 ECU must be programmed to tell it to run analog gauges instead of digital. Where can I get that done?
You need an AGI box. As far as I know you do not need a reprogram, I just had this done this winter.
redbud35 is offline  
Reply With Quote
Old 06-02-2009, 08:17 AM
  #9
Registered
Trade Score: (5)
 
Join Date: Oct 2005
Location: Clarkston, Michigan
My Boats: 22 Donzi Classic 525 EFI
Posts: 4,636
Default

Quote:
Originally Posted by redbud35 View Post
You need an AGI box. As far as I know you do not need a reprogram, I just had this done this winter.
OK, thanks. I'll get parts ordered today from Bam. This thread was a big help.
thirdchildhood is offline  
Reply With Quote
Old 06-03-2009, 08:13 AM
  #10
Registered
Trade Score: (5)
 
Join Date: Oct 2005
Location: Clarkston, Michigan
My Boats: 22 Donzi Classic 525 EFI
Posts: 4,636
Default

Orthos, how did this work out for you? I had to order the complete rigging kit and AGI box. I will need to have the computer programmed to put out an analog tach signal. The guys at Bam were really helpful. They answered my e-mail within an hour, called Mercury and got the info I needed to order what I needed. Now hopefully I can get this thing on the water soon.
thirdchildhood is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:40 AM.


Copyright 2011 OffShoreOnly. All rights reserved.