Go Back  Offshoreonly.com > General Discussion > General Boating Discussion
Big Thanks, To Mark and Chris @ Precision Marine >

Big Thanks, To Mark and Chris @ Precision Marine

Like Tree0Likes

Big Thanks, To Mark and Chris @ Precision Marine

Reply

Old 01-16-2010, 02:59 PM
  #1
Registered
Thread Starter
 
Join Date: Jun 2007
Location: Denham Springs La.
My Boat: 2008 26' Revolution Performance Marine
Posts: 606
Default Big Thanks, To Mark and Chris @ Precision Marine

Just wanted to give Mark and Chris at Precision Marine a big thanks for the great work that they did on my engine over the past couple of months....They went above and beyond on testing and tuning of my motor.

Will have Dyno sheets in a few, but engine made 1071hp, and 998 ftlbs of torque, here are a few pics and a video of the Dyno run... Enjoy!!!

http://www.youtube.com/watch?v=BwVJkU7sZX0
Attached Thumbnails Big Thanks, To Mark and Chris @ Precision Marine-img00056-20100115-1050.jpg   Big Thanks, To Mark and Chris @ Precision Marine-img00057-20100115-1050.jpg   Big Thanks, To Mark and Chris @ Precision Marine-img00058-20100115-1050.jpg  

26 REDLINE is offline  
Reply With Quote
Old 01-16-2010, 03:03 PM
  #2
Platinum Member
Platinum Member
 
Jassman's Avatar
 
Join Date: Oct 2000
Posts: 9,374
Default

congrats.. looks good.. love the dyno room... what's your estimated new top speed..
Jassman is offline  
Reply With Quote
Old 01-16-2010, 03:14 PM
  #3
Registered
Thread Starter
 
Join Date: Jun 2007
Location: Denham Springs La.
My Boat: 2008 26' Revolution Performance Marine
Posts: 606
Default

Originally Posted by Jassman View Post
congrats.. looks good.. love the dyno room... what's your estimated new top speed..
Hey Jeff, I am going with a new SCX 1:24, with a Maximus prop, I had a a 1:35, and was running Bravos, working the numbers I should be in the 137-140 range, the motor is putting out about 50 more hp after the refresh...so we will see
26 REDLINE is offline  
Reply With Quote
Old 01-16-2010, 03:20 PM
  #4
Platinum Member
Platinum Member
 
Jassman's Avatar
 
Join Date: Oct 2000
Posts: 9,374
Default

Originally Posted by 26 REDLINE View Post
Hey Jeff, I am going with a new SCX 1:24, with a Maximus prop, I had a a 1:35, and was running Bravos, working the numbers I should be in the 137-140 range, the motor is putting out about 50 more hp after the refresh...so we will see
Damn...thats fast.. and Big Balls on a 26...
Jassman is offline  
Reply With Quote
Old 01-16-2010, 03:21 PM
  #5
Platinum Member
Platinum Member
 
Ptufaro's Avatar
 
Join Date: May 2003
Location: Metairie, La.
Posts: 667
Default

Looks great was tryin to make it back over to see it run, but I am sure I will see you on the water.
Great job
Ptufaro is offline  
Reply With Quote
Old 01-16-2010, 03:22 PM
  #6
Registered
Thread Starter
 
Join Date: Jun 2007
Location: Denham Springs La.
My Boat: 2008 26' Revolution Performance Marine
Posts: 606
Default

Originally Posted by Jassman View Post
Damn...thats fast.. and Big Balls on a 26...
The boat is super stable there is no real differance in the boat between 90mph and 130, it doesn't do anything funny, we meet up on the river I will give you a ride, you might get neorvous going around a curve at about a buck 20...
26 REDLINE is offline  
Reply With Quote
Old 01-16-2010, 03:25 PM
  #7
Registered
Thread Starter
 
Join Date: Jun 2007
Location: Denham Springs La.
My Boat: 2008 26' Revolution Performance Marine
Posts: 606
Default

Originally Posted by Ptufaro View Post
Looks great was tryin to make it back over to see it run, but I am sure I will see you on the water.
Great job
Thanks Pete, it was great meeting you, yea the motor came out great, and sounded so strong, I think I have reached the top with my little 540, I just got a kick out of it surprising Mark...I should have made a bet with him...
26 REDLINE is offline  
Reply With Quote
Old 01-17-2010, 08:35 AM
  #8
Registered
Thread Starter
 
Join Date: Jun 2007
Location: Denham Springs La.
My Boat: 2008 26' Revolution Performance Marine
Posts: 606
Default

Originally Posted by Elite Marine View Post
How many hours did you put on that TPI Engine? Seems like it was just built yesterday!

Glad to hear you're happy and making great power.

Kirk
Thanks Kirk,

The engine only had about 150hrs, it didn't need to be refreshed, just wanted to be safer than sorry. I don't know if anyone knew or not, but this was the first TPI 848 that he built and it was a mule motor but once Mark and the guys at Precision Marine tore in to it, it really was in great shape, only a little blow by. I have been very happy with the engine, not one problem, and hopefully with this new SCX I won't have as many drive problems...
26 REDLINE is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser