Like Tree0Likes

question for the Ilmor V-10 guys !

Reply
Old 05-23-2011, 12:54 PM
  #11
Registered
 
Join Date: Nov 2005
Posts: 863
Default

Quote:
Originally Posted by fantastixvoyage View Post
Is this the boat that sat at Lake Cumberland for YEARS?! Always liked the idea but heard it was a bit of a handful. It was there back in '05 when I ran the two ilmor talons that were also there.

Have your buddy talk to ilmor about doing some upgrades. The 550s were pretty old school compared to what they are doing now (dress and power). Believe these had the coolers in the rear if I'm not mistaken.
Good memory! Spot on.
ILMORdude is offline  
Reply With Quote
Old 05-23-2011, 04:19 PM
  #12
Registered
VIP Member
Thread Starter
 
berns29scarab's Avatar
 
Join Date: Jul 2004
Location: Brick, NJ
Posts: 6,969
Default

Quote:
Originally Posted by C_Spray View Post
Ilmor is the primary sponsor of the New Jersey Performance Powerboat Club for 2011. If the owner is a member of NJPPC, he might be able to get some favorable treatment from Ilmor. I don't know for a fact; Imjusayyin...
i will forward that info along to him
berns29scarab is offline  
Reply With Quote
Old 05-23-2011, 04:20 PM
  #13
Registered
VIP Member
Thread Starter
 
berns29scarab's Avatar
 
Join Date: Jul 2004
Location: Brick, NJ
Posts: 6,969
Default

boats only got 57 hours on it...dont think he'll be wanting to do any upgrades yet lol...if its not broke dont fix it
berns29scarab is offline  
Reply With Quote
Old 05-23-2011, 04:29 PM
  #14
Registered
Trade Score: (1)
 
Join Date: Jul 2003
Location: Michigan
My Boats: 29 PHANTOM 36 SKATER 38 POWERQUEST
Posts: 3,193
Default

Quote:
Originally Posted by berns29scarab View Post
...if its not broke dont fix it

Since when?!


Tell him to get used to the boat. With the low hours I bet its the same one I'm thinking of. Seem to recall the boat was a bit squirrely at speed. Im sure even if it is it could be worked out (if it hasn't already). Rik on here may be a good one to touch base with on this particular boat to be sure.

Have a blast and be safe!!!

(btw bern I still owe ya details on my triple trailer, shoot you an email tonight)
fantastixvoyage is offline  
Reply With Quote
Old 05-23-2011, 04:57 PM
  #15
Registered
 
Machz1000's Avatar
 
Join Date: Jul 2006
Location: Gallatin, Tn
My Boats: 2003 Skater 32
Posts: 26
Default

The water pumps on the 550s are an old design than what Ilmor uses now. But I have had no problem with them. If the boat has been in salt water and they werent flushed immediatly they corrode on the inside and the bushing that holds the shaft wears out and causes the impellers to premeturely wear and fail. I replaced my housings and they work great. If you take the impellers out and they have broken apart the rubber pieces will go through the housing and plug up your coolers. Usually the first cooler after the water pump. But I found pieces in both the oil cooler and the engine coolant cooler. Not easy to flush. The pieces will not go backwards through the system and come out.

Also, you need to pressure check the headers on a regular basis. The early design headers are weak at the collector and the welds crack and cause water to be sucked in the bottom two tubes and in to the combustion chamber of the 8 and 10 cylinders or the 7 and 9. This causes the engine to hydraulic and parts broke. Happend to me and I had to fix a head (four valves and weld up) and replace two pistons and resleeve a cylinder!! Not a easy fix.

Just some helpful info on the Viper Engine.

Just for thought- I have 600hrs on both my engines with the stock rods crank and pistons. Clearences are still perfect!!! These motors are awesome.
Machz1000 is offline  
Reply With Quote
Old 05-23-2011, 05:16 PM
  #16
Registered
VIP Member
Thread Starter
 
berns29scarab's Avatar
 
Join Date: Jul 2004
Location: Brick, NJ
Posts: 6,969
Default

here ya go
Attached Thumbnails
question for the Ilmor V-10 guys !-hustler5.jpg   question for the Ilmor V-10 guys !-hustler1.jpg   question for the Ilmor V-10 guys !-hustler3.jpg  

berns29scarab is offline  
Reply With Quote
Old 05-23-2011, 05:19 PM
  #17
Registered
VIP Member
Thread Starter
 
berns29scarab's Avatar
 
Join Date: Jul 2004
Location: Brick, NJ
Posts: 6,969
Default

the water pumps on this specific boat are Keith Eikert pumps (according to the ensignia on the backing plates)
MachZ thanks for the input
berns29scarab is offline  
Reply With Quote
Old 05-23-2011, 05:25 PM
  #18
Diamond Member #001
Charter Member
Trade Score: (2)
 
C_Spray's Avatar
 
Join Date: Oct 2000
Location: Coastal North Carolina
My Boats: 2000 Formula 382 with Innovation 600's
Posts: 4,789
Default

Quote:
Originally Posted by fantastixvoyage View Post
...Tell him to get used to the boat. With the low hours I bet its the same one I'm thinking of. Seem to recall the boat was a bit squirrely at speed. Im sure even if it is it could be worked out (if it hasn't already). Rik on here may be a good one to touch base with on this particular boat to be sure...
Certainly, having 400 pounds less engine weight would move the CG further forward. On the other hand, there have been at least two other 388's with Arneson's and big power, so I'm sure the setup will work. The two boats that I remember were "Double Trouble" and "Black Cloud", which had HUGE power, and ran some really big numbers. I personally saw Double Trouble run a solid 110+. Like you said, if there are any issues, the Arneson guys would be my first call.
__________________
Retired! Boating full-time now.

Last edited by C_Spray; 05-23-2011 at 09:04 PM.
C_Spray is offline  
Reply With Quote
Old 05-23-2011, 05:34 PM
  #19
Registered
VIP Member
Thread Starter
 
berns29scarab's Avatar
 
Join Date: Jul 2004
Location: Brick, NJ
Posts: 6,969
Default

we ran it into the low 90's yestrerday in 10-12 mph winds n im guessin 1 ft barnegat bay slop and was stable as a rock. i was also in one years ago early 2000's with 675 eikerts n arnesons and that one was a handful and ran low 1teens...that one had to be trimmed to the moon to get it over 95 and to assist with settling her down
berns29scarab is offline  
Reply With Quote
Old 05-23-2011, 05:39 PM
  #20
Registered
VIP Member
Thread Starter
 
berns29scarab's Avatar
 
Join Date: Jul 2004
Location: Brick, NJ
Posts: 6,969
Default

n another
Attached Thumbnails
question for the Ilmor V-10 guys !-hustler4.jpg   question for the Ilmor V-10 guys !-hustler2.jpg  
berns29scarab is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:13 PM.


Copyright 2011 OffShoreOnly. All rights reserved.