Like Tree0Likes

Mon.Morn,damage report on Tues.

Reply
Old 09-03-2002, 02:55 PM
  #11
Charter Member
Charter Member
 
Dean Ferry's Avatar
 
Join Date: Nov 2000
Location: Merritt Is. Fl. USA
My Boats: 2006 Hustler 388, 2004 Hustler Talon 25, 1999 30 Spectre cat and 2007 21' hydrostream voyager w/ Merc. 225 EFI
Posts: 6,580
Default

KILLED a couple thousand brain cells @ our 3rd annual Labor day "Ferry's TIKI bar" party. That damn Amber Lager that my buddy Kevin brews, that beer is soooooo good!!
The Velocity ran great, drove down to Satelite beach, picked up my oldest daughter for the weekend and let her drive all the way back home!
MAJOR DAMAGE? $ 430,000.00 Mama found a new home she wants, here's the view out back!
MD
Attached Thumbnails
Mon.Morn,damage report on Tues.-mvc-001s.jpg  

Last edited by Dean Ferry; 09-03-2002 at 03:01 PM.
Dean Ferry is offline  
Reply With Quote
Old 09-03-2002, 02:57 PM
  #12
DJD
Registered
 
Join Date: Oct 2000
Location: Greenwich CT. U S of A
My Boats: 38' Cigarette, 42'Post, Driver:F2-07 Wild Child
Posts: 1,839
Default

Well, I finally had to add my first quart of oil since I ran my Post up from FL .
Going slow has its advantages!
I havent used my Cigarette once this yr
DJD is offline  
Reply With Quote
Old 09-03-2002, 03:07 PM
  #13
Registered
 
Turbojack's Avatar
 
Join Date: Sep 2001
Location: Houston, TX, USA
My Boats: 2003 Eliminator 30' Daytona
Posts: 2,285
Default

Boat ran good.

Waverunner GP1200R motor froze up. Sure glad got the Yamaha "YES" 3 year warranty.
Turbojack is offline  
Reply With Quote
Old 09-03-2002, 04:47 PM
  #14
Registered
 
BigDaddy96's Avatar
 
Join Date: Jul 2002
Location: LOTO / KC
My Boats: 2002 353 Fastech (for sale) http://midwestboatparty.com/bd/formula.htm
Posts: 618
Default

Boat ran fine all weekend.

However, one of our guests dropped our 35mm camera in the water at the DOCK!
Oh well at least it wasn't the digital.
BigDaddy96 is offline  
Reply With Quote
Old 09-03-2002, 09:28 PM
  #15
Bo Knows
Guest
 
Posts: n/a
Default

This weekend, speedo stopped working, latch on cabin door broke, & bolts on rt side trailer bunk broke. Not a bad weekend.Went out today & bought grade 8 stainless bolts & repaired trailer, located & wire tied hose for speedo that fell off outdrive & ordered new door latch from Checkmate. I'll be ready to go out & break some more stuff trhis weekend. I can hardly wait !

Bo
 
Reply With Quote
Old 09-03-2002, 09:41 PM
  #16
Charter Member #927
Charter Member
 
Payton's Avatar
 
Join Date: Jan 2001
Location: IN
My Boats: 1991 34' Super Hawaii
Posts: 4,817
Default

Everything ran great all weekend. We even went out today for one of those "business lunches" fun waves out there today.

But, I had one rough night when I thought I lost my wallet in Holland MI, Sunday. It had to have fallen out of my pocket onto the deck of the boat as I was tarping the boat in the slip. My wallet was under that tarp. that was fine untill a storm blew in and blew my tarp off. 2 Sea Ray cruisers from Chicago that were next to me, put the tarp back on for me and found my wallet laying just 6" from the edge of the boat. It would've fallen into 20' of water. It's amazing that the tarp didn't slide it into the drink when the tarp blew off. The guys tossed it down into the cabin. Now I have to wait for all my new credit cards to come, I cancelled them all just to be safe.

Thanks to a few very cool fellow boaters!!

Mark
Payton is offline  
Reply With Quote
Old 09-03-2002, 09:42 PM
  #17
Charter Member #1055/Moderator
Charter Member
Trade Score: (1)
 
GO4BROKE's Avatar
 
Join Date: Feb 2001
Location: CNY
My Boats: Sonic 386
Posts: 4,579
Default

Still not sure what broke this weekend!! I lost 3-400rpm's on BOTH motors and 4 mph WOT. Not quite sure whats up, but I'll start with a tune up and go on from there.
__________________
[img][/img]
GO4BROKE is offline  
Reply With Quote
Old 09-03-2002, 09:52 PM
  #18
Charter Member #232
Charter Member
 
Audiofn's Avatar
 
Join Date: Oct 2000
Location: Carlisle, MA USA
My Boats: 1979 Formula 302, 99 Formula 353, 81 Donzi 18 2+3 with 454
Posts: 18,379
Default

Well I fixed my one alternator and tested the other and that one is not 100% either. Man does it ever stop!!! I am going to pull in tomarrow am and have it tested and rebuild if need be. It only has maybe 10 hours on it unfortunatly it is out of warrantee

Jon
__________________
Put your best foot forward!
Audiofn is offline  
Reply With Quote
Old 09-03-2002, 09:58 PM
  #19
Charter Member#157
Charter Member
 
MnFastBoat's Avatar
 
Join Date: Oct 2000
Location: Minneapolis, Mn, Usa
My Boats: 1999 Advantage 28' Cat
Posts: 1,847
Default

well I am surprised ot say the least that mine has encounted some sort of small boat advisory limitations from LOTO

Sat leaving party cove I choose to stuff my cat down by where the main channel meets by Shooters21.
Came up of a few crusiers wakes

Aluminum rubrail pulled about 6 rivets out and lost the rubber insert.
Sunday I squezzed the rubber insert back in but lost the first half under the Community bridge. Cut that part off and by the time i made it to Party Cove, the rest was gone.
Good thing I have a new insert here at home. Project for tomorrow.
__________________
This Cat is trying to keep up with the Big Dogs
MnFastBoat is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
docmanrich37
General Boating Discussion
10
07-03-2005 09:20 AM
mopower
General Boating Discussion
10
09-23-2002 06:08 PM
mopower
General Boating Discussion
30
09-09-2002 06:32 PM
nautigirl
General Boating Discussion
10
01-29-2002 04:35 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:19 PM.


Copyright 2011 OffShoreOnly. All rights reserved.