Go Back  Offshoreonly.com > General Discussion > General Boating Discussion
Need setup pros! Boat won't run what it's supposed to... >

Need setup pros! Boat won't run what it's supposed to...

Notices

Need setup pros! Boat won't run what it's supposed to...

Old 05-08-2016, 08:40 PM
  #1  
Registered
Thread Starter
 
Join Date: Jul 2009
Location: Fredericksburg, VA
Posts: 793
Likes: 0
Received 3 Likes on 3 Posts
Default Need setup pros! Boat won't run what it's supposed to...

I'm starting to pull my hair out. I bought an '06 Nortech 3900V that needed some TLC. Boat has sat for years and I'm finally getting it back to top condition. The boat is a full stagger with ITS, 555ci fuel injected Eddie Young motors making 700HP. They were just freshened (as in I just picked it up). The boat when new ran 97 MPH, I've confirmed this from a few people. With a few years age the original owner claims it became a 94-95 MPH boat every day. He confirmed the day he traded it in he remembers running the boat out and it was 100%. So here I am now and the boat struggles with 89 MPH. It's quick to get there but that's all that's in her. The thing that's confusing is the slip, to get the RPM up I have to trim decently high. I see 89 MPH at 5500RPM with 1.5 ratio spinning 34P Maximus props. That's 25% plus slip. The boat will not pull RPMs tucked in. If I trim it back in while running up top even a touch it scrubs speed and r's quickly. Any input welcome!
Jpzaluski is offline  
Old 05-08-2016, 08:49 PM
  #2  
Registered
 
Join Date: Apr 2015
Posts: 1,168
Received 28 Likes on 18 Posts
Default

Whats changed on the boat since he ran his number... how do you know he isnt full of chit?
iliveonanisland is offline  
Old 05-08-2016, 08:52 PM
  #3  
Registered
 
Join Date: Apr 2015
Posts: 1,168
Received 28 Likes on 18 Posts
Default

If you washed the boat with regular soap instead of special speed soap, you probably stripped the speed wax off the bottom of the boat, causing much more drag...
iliveonanisland is offline  
Old 05-08-2016, 09:16 PM
  #4  
Registered
 
Join Date: Jan 2016
Location: New York
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Default

Try a few sets of props to confirm your slip numbers. Take notes at all trim heights. Make real sure the tachs are the same, you may have a motor problem and one motor dragging down the other. Most time when people buy new boats the old owner swaps props this is very common. Always remember no one gives up there good props, no matter what they say.
Equalizer is offline  
Old 05-09-2016, 06:45 AM
  #5  
dcb
Registered
Platinum Member
 
Join Date: Aug 2007
Location: Falmouth, Va/ PGI, Fl
Posts: 448
Received 2 Likes on 1 Post
Default

On my gun, the Maximus props are not my top speed prop, they are a great all-around prop. My stock bravos are about 3-4 mph faster top end.
dcb is offline  
Old 05-09-2016, 12:47 PM
  #6  
bor
Registered
iTrader: (1)
 
bor's Avatar
 
Join Date: Oct 2007
Location: uithoorn,the netherlands
Posts: 728
Received 4 Likes on 2 Posts
Default

reading youre post look to me youre props are to big and you just trim so high that they loose grip and that get the slip number so high ,I would try a smaller set and also like dcb said the maximus are mostly not the fastest prop so maybe try a set 34 bravo 1 that will give you more rpm s due to the less blades .
bor is offline  
Old 05-09-2016, 03:57 PM
  #7  
Registered
 
Tinkerer's Avatar
 
Join Date: Jan 2002
Location: ALTO, MI
Posts: 4,612
Received 5 Likes on 4 Posts
Default

He would not be getting to top speed " real fast " if the props were too big. Any chance the boat has taken on weight ( water ) up front. Sounds like you are over trimming to carry the bow. any chance the boat originally had -2 inch shorties on it and the drives got swapped to his new boat?
Tinkerer is offline  
Old 05-09-2016, 05:06 PM
  #8  
Registered
 
Join Date: Aug 2012
Location: TRL
Posts: 516
Likes: 0
Received 2 Likes on 1 Post
Default

Are the tabs stuck down? lol
keegan is offline  
Old 05-09-2016, 05:26 PM
  #9  
Registered
 
Join Date: Oct 2015
Location: Lake George, NY
Posts: 1,244
Received 3 Likes on 3 Posts
Default

All Salt water numbers?
class6 is offline  
Old 05-09-2016, 07:23 PM
  #10  
CLA
Registered
 
Join Date: Dec 2008
Posts: 605
Likes: 0
Received 0 Likes on 0 Posts
Default

Check the toe on the drives.

Try different sets of props.

What does NT say about spinning the props in or out?
CLA is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.