Like Tree0Likes

C4 Corvette Problems

Reply
Old 09-18-2003, 11:43 AM
  #1
Registered
Thread Starter
 
HyperBaja's Avatar
 
Join Date: Sep 2002
Location: Lewis Center, Ohio
My Boats: 1990 Baja 190 DSR
Posts: 3,606
Default C4 Corvette Problems

No, I didnt break it, dad has.
First Problem- When starting after it has set for more than a few hours, it takes a while to finally start. Turns over fine, just wont kick over on its own. When it does, it smells REALLY RICH. Fuel injector problem?

Second Problem-Brakes...Brake light is on like when you have the hand brake on. petal is VERY light, and dosent like to stop much. Brake master solenoid?

Edit-It is a 1988 TPI Corvette with 51k miles.
HyperBaja is offline  
Reply With Quote
Old 09-18-2003, 11:47 AM
  #2
Registered
 
SS930's Avatar
 
Join Date: Aug 2003
Location: At the office.
My Boats: 1990 Donzi Sweet 16
Posts: 6,684
Default

1-Leaking injector, cold start injector

2-Check the fluid level, bad master cylinder, old fluid, leak in system

Just some VERY QUICK thoughts
SS930 is offline  
Reply With Quote
Old 09-18-2003, 11:48 AM
  #3
Member #154
Platinum Member
 
Indy's Avatar
 
Join Date: Oct 2000
Location: SW CT & Long Island Sound
My Boats: Missing my PowerPlay
Posts: 6,756
Default

Post over at www.corvetteforum.com There's a C4 section that will help you.
Indy is offline  
Reply With Quote
Old 09-18-2003, 12:15 PM
  #4
lottawatta
Guest
 
Posts: n/a
Default

HyperBaja,
Hold the accelerator down to the floor when cranking, if I start right up, it is the injectors leaking down. Had the same problem on my C4. Injectors fixed it.
Brakes: no idea.

Corvetteforum.com Rules!
 
Reply With Quote
Old 09-18-2003, 12:51 PM
  #5
Forum Regulator
VIP Member
Trade Score: (1)
 
Sydwayz's Avatar
 
Join Date: May 2001
Location: Worldwide
My Boats: 17' Speedliner Cat & O.P.B.
Posts: 21,920
Default

The brake light being on; half lit, might be an indicator of an ABS problem. Same problem on my 1989 S-10 Blazer. See if you can find a verticle mounted ABS controller next to the master cylinder, and unplug the connector off of the back of it. It is a long connector, and the box is about the size of two slices of bread next to each other ( ll ). If the light goes out, you have found your problem.
Sydwayz is offline  
Reply With Quote
Old 09-18-2003, 12:54 PM
  #6
Registered
 
TEAMBAJA's Avatar
 
Join Date: Dec 2002
Location: Bucyrus, Ohio
My Boats: 24 OUTLAW
Posts: 6,654
Default

Quote:
Originally posted by lottawatta
HyperBaja,
Hold the accelerator down to the floor when cranking, if I start right up, it is the injectors leaking down. Had the same problem on my C4. Injectors fixed it.
Brakes: no idea.

Corvetteforum.com Rules!

After the 95 speeding ticket in the Ranger, I dont think HyperBaja should even sit in a Corvette!
TEAMBAJA is offline  
Reply With Quote
Old 09-18-2003, 01:07 PM
  #7
Registered
 
Join Date: Sep 2001
Location: Chesaning, Mi
My Boats: 1997 225 BR Crownline.............
Posts: 152
Default

Yes, I Thought He Had Trouble Keeping Rubber On The Rear Tires!!!!!!!!!!!!!!!
neu-rich is offline  
Reply With Quote
Old 09-18-2003, 03:08 PM
  #8
Registered
Thread Starter
 
HyperBaja's Avatar
 
Join Date: Sep 2002
Location: Lewis Center, Ohio
My Boats: 1990 Baja 190 DSR
Posts: 3,606
Default

No, I havent done a lot of burn outs in that car, but the 0-45 is faster than I have time to take the foot off the gas haha, gotcha.
HyperBaja is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
HyperBaja
General Boating Discussion
6
12-18-2003 11:10 PM
Back4More
General Boating Discussion
32
11-22-2003 04:32 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:48 AM.


Copyright 2011 OffShoreOnly. All rights reserved.