Offshoreonly.com

Offshoreonly.com (https://www.offshoreonly.com/forums/)
-   General Boating Discussion (https://www.offshoreonly.com/forums/general-boating-discussion-51/)
-   -   Hey LOTO! Sucks being without my boat so far this year! (https://www.offshoreonly.com/forums/general-boating-discussion/82160-hey-loto-sucks-being-without-my-boat-so-far-year.html)

bmpnugls 06-26-2004 11:21 PM

Looking for advise.....Hey LOTO! Sucks being without my boat so far this year!
 
Hey LOTO guys, it's been a while since I've posted, since early this spring I started a new job (better opportunity, etc.), But, I've also been trying to resolve a 'winterization' issue with the marina where I keep my boat!.. They winterized it in Oct. of last fall and dewinterized it in March...well, upon me running the boat for the first time this season in April, the port engine had milky oil!!!!.... so, the diagnosis begins, and after realizing the marina service technicians weren't competent enough to do simple pressure checks on the engine to identify the location of the water contamination...and I paid a visit to my boat to find the exhaust manifolds, distributor, carb., spark plugs, and heat exchanger removed - "as part of their diagnosis" as they said, when they couldn't or wouldn't even give me any results from a compression check, or pressure checks of the raw or closed cooling system - they just said they "needed to tear into it to determine the problem"...B.S.! Not to mention they had left all these parts in the cockpit of my boat, uncovered, open to the elements!!! and the plugs, etc. out of the engine - exposed to the elements!!!!!

Since, after hiring the awesome guys at Advanced Marine (Matt and Steve and co.), the exhaust manifolds/risers and oil cooler have been pressure checked - all good!..the heads were removed and magnafluxed - all good....and no indication of a 'top end' water leak - all plugs looked normal, and all cylinders/piston tops looked normal (not washed or clean to indicate a bad head gasket) and both head gaskets looked in great shape...so, the leak/crack has been confinded to the short block!!!...which is a closed cooling system...but, I very seriously doubt they checked the antifreeze mix when they winterized it.....which in disucsions with the original marina (which by the way is Dave Mungenast Marina) they basically admitted they didn't check the closed cooling system antifreeze - - - BECAUSE, they said that is my responsibility!!! BUT, they failed to realize their winterization contract says they will check the antifreeze mix, on closed cooling systems!!!... AND, they are claiming that the damage is due to lack of service/flush of my closed cooling system has allowed the block to corrode to a point where it has cracked....now, I'm not ready to believe that, since the boat/engines are 1994's and with around 300 hours total, I find it very hard to belive that is a possibility......but, I did just buy this boat last July, and hadn't personally checked the antifreeze mix content, nor do I know when the last time the system was flushed...but, still, a block corroding to that point in 10 years!??

Anyway, I needed to vent on this because Mungenast Marina is claiming they are not responsible for the damage and it's not a winterizing issue!!! And, I haven't been able to use the boat all year so far due to waiting/arguing with them...but, finally, out of my own pocket, I'm having the guys at Advance replace the engine hopefully by the week after July 4th...and I'll be able to go boating again......and the legal suit will begin with Mungenast!

So, hope to be joining you guys on the lake soon!!!!....

bmpnugls 06-26-2004 11:37 PM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
Oh ya,,,by the way, if your wondering the boat is my new cruiser purchase of a 1994 Silverton 34 express...which has twin 454xl crusaders...(thus the closed cooling system part)...

bmpnugls 06-28-2004 08:36 AM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
So, how's the action been at party cove so far this year?

dyno 06-28-2004 09:17 AM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
should have kept the Fountain!!!hope you get things resolved I feel your pain.....

stevebaretta 06-28-2004 09:34 AM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
That whole deal sucks. I'd have a sit down with your attorney. Be sure to take your receipts from Adanced Marine so you know how much to go after. Good luck!

bmpnugls 06-28-2004 10:35 AM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
Ya, if Mungenast does not become cooperative really soon, and it does go to court...I will be going after more than my 'repair' bill with Advanced!!! because I'm going through a hell of a lot of "pain and suffering" right now!!!!

bmpnugls 06-28-2004 10:36 AM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
Oh, and dyno....I saw the 'Fountain' listed with a broker at the Lake of the Ozarks a couple weeks ago - - - for sale again....when I saw that, I about puked thinking about the fun I could be having right now if I hadn't sold it!!!

bmpnugls 06-29-2004 08:28 AM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
bump for any advise...

dyno 06-29-2004 09:01 AM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
that was one cool 10 meter!

bmpnugls 06-29-2004 09:59 AM

Re: Hey LOTO! Sucks being without my boat so far this year!
 
Ya, it got tons of 'looks' at the docks! - - always a conversation piece..


All times are GMT -5. The time now is 03:04 PM.


Copyright 2011 OffShoreOnly. All rights reserved.