Go Back  Offshoreonly.com > Technical > General Q & A
Crownline 225 CCR 454 MAG is slow!!! >

Crownline 225 CCR 454 MAG is slow!!!

Like Tree14Likes

Crownline 225 CCR 454 MAG is slow!!!

Reply

Old 09-16-2019, 09:48 PM
  #31
Registered
Thread Starter
 
Join Date: Dec 2017
Posts: 155
Default

Originally Posted by bobl View Post
I donít get on here much anymore since I retired, but I saw this thread and thought I would share some hard earned experience. As many of you know Iíve spent a lot of time messing with Crownlines. Iíve built engines, setup and driven probably 25-30 of them in the past 25 years, many with 600+ HP. So, hereís what I know. The 225 CCR will run 60-62 with a 454 Mag. and a 1.5:1 Bravo 1 drive and 21 Mirage+. That is by far the fastest prop. Most came with 2.00:1 B3 drives. I built a 600hp 540 for a red 225CCR (just like in the video posted). It would run 70 on a good day. I did a 225 BR with a built 454 with a Whipple that made 750 HP. With a Stern Jack and hydraulic steering it saw a best of 81 on GPS. As far as I know thatís the fastest a Crownline has been, except maybe behind a truck!
This is what iwas looking for someone who knew these boats. 62 mph is what im expecting but I think I know what's going on. When i first tested the boat i borrowed a bravo one prop didn't care what it was but a buddy let me borrow it so I could test the boat. That coupled with bad GPS explains the high 60's. The very next day I bought a cheap prop of Facebook to get the boat on the water. Then I bought the laser ii thinking it was a 14 1/2 diameter. It's 13 1/4 which explains the slip I was feeling. I still have the bravo one 4 blade that supposedly 62 64 mph but it's bent and needs work. I just picked up a 15.25 x 21p from powertech the osf3. It has a Honda hub in it and I had powertech send me the correct hub for the mercury. Supposedly this prop is most like the mirage. Hoping this makes a difference but considering the two different diameters I can see the issue now. Do you think i can expect better cruise speed with this prop? I'll take it out this weekend.
cableguy1979 is offline  
Reply With Quote
Old 09-16-2019, 09:55 PM
  #32
Registered
Thread Starter
 
Join Date: Dec 2017
Posts: 155
Default

Originally Posted by Gimme Fuel View Post
I am thinking your tachometer is reading 500 rpm high. That MPI motor has a 5150 rpm rev limiter....meaning you never hit that claimed 5700 rpm with that 18p prop. So that 5000 rpm with the 25p prop is likely only 4500 rpm. So, being over-propped with a smaller diameter Laser (not good on bigger/heavy hulls) you are probably getting slip. So far what you HAVEN'T done yet is put something close to original stated prop on the boat. Both you have tried are on the extreme ends of what the boat needs (too small vs. too big) and boats are really sensitive to that. sometimes going to a smaller prop gains speed if you are over-propped. Too small and you loose speed because you simply are limited to 5150 rpm.
Im not doubting you here. However someone toldme yesterday the mag efi/mp not mpi didn't have a rev limiter but the original owner told me he's hit the rev limiter before so I obliged to believe your are correct and my tack might be off . If that's the case my cruise speed could be much higher because I'm not turning 3200 rpm like I think I am and instead would be turning 2700 rpm even when the tack is saying 3200. I'll have to find a way to test it.
cableguy1979 is offline  
Reply With Quote
Old 09-17-2019, 05:41 AM
  #33
Registered
 
Join Date: Oct 2012
My Boat: 280 Velocity
Posts: 1,233
Default

First things you need to do is get an accurate tach and GPS.
underpsi68 is offline  
Reply With Quote
Old 09-17-2019, 07:10 AM
  #34
Registered
 
Join Date: Oct 2010
Location: Hemlock, MI
My Boat: 2000 Powerquest 380 Avenger
Posts: 757
Default

Originally Posted by cableguy1979 View Post
Im not doubting you here. However someone toldme yesterday the mag efi/mp not mpi didn't have a rev limiter but the original owner told me he's hit the rev limiter before so I obliged to believe your are correct and my tack might be off . If that's the case my cruise speed could be much higher because I'm not turning 3200 rpm like I think I am and instead would be turning 2700 rpm even when the tack is saying 3200. I'll have to find a way to test it.
Merc EFI motors all have built in rev limiters...period. 454 and 502 MAG MPI with MEFI controllers is 5150 rpm.
Gimme Fuel is offline  
Reply With Quote
Old 09-22-2019, 09:08 AM
  #35
Registered
Thread Starter
 
Join Date: Dec 2017
Posts: 155
Default

Ok seems the new 15.25x21 stopped the ventilation boat picked up good and cruises around 3000 rpms well. However 45 minutes into cruising i lost rpm and it died and just clicks wont turn over guess I'll start a new post. Im not sure if im looking at a hydrolocked situation or gimbal bearing.
cableguy1979 is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser