Go Back  Offshoreonly.com > Technical > General Q & A
Boat won’t stay w trim connected to battery. >

Boat won’t stay w trim connected to battery.

Notices

Boat won’t stay w trim connected to battery.

Old 06-25-2022, 07:38 PM
  #1  
Registered
Thread Starter
 
Join Date: Jun 2022
Location: Norman, OK
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default Boat won’t start w trim leads connected to battery.

Hello and thanks for reading.

If the trim leads are connected to the battery the starter only clicks when attempting to start. If I remove the leads to the trim assembly the boat starts. I have already replaced both relays on the trim motor. Trim up and down works fine. I know there is that 110v fuse on the main positive lead where it connects to the trim pump relays. Could that cause that issue?

I have cleaned the ground connection on the block.
I have no corrosion on the battery.
I have the leads down right on the battery posts.


I’m so lost. It almost seems like the trim is draining the battery.

any insight would be greatly appreciated!

Last edited by CapnKirk323; 06-26-2022 at 04:44 PM.
CapnKirk323 is offline  
Old 06-26-2022, 07:10 AM
  #2  
Registered
 
Join Date: Oct 2000
Location: Lake Ozark, MO USA
Posts: 723
Received 229 Likes on 129 Posts
Default

Does the trim wire spark when you connect it to the battery post? Yes, fault in trim circuit, relay or switch.
Helmwurst is offline  
Old 06-26-2022, 07:30 AM
  #3  
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 12,507
Received 2,165 Likes on 930 Posts
Default

Any chance of taking pic where your trim power wire is attached to battery power ?
SB is offline  
Old 06-26-2022, 03:29 PM
  #4  
Registered
Thread Starter
 
Join Date: Jun 2022
Location: Norman, OK
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default No spark when applying positive cable to battery.

No spark. Here are some pics. We’ll it won’t let me post pics for some reason…

Last edited by CapnKirk323; 06-26-2022 at 03:35 PM.
CapnKirk323 is offline  
Old 06-26-2022, 04:08 PM
  #5  
VIP Member
VIP Member
 
Join Date: Nov 2005
Location: Wichita, Kansas
Posts: 598
Received 315 Likes on 149 Posts
Default

Originally Posted by CapnKirk323 View Post
No spark. Here are some pics. We’ll it won’t let me post pics for some reason…
You need 10 posts I believe...just post a period or a word ten times...
__________________
Baja 252 Islander
bajaman is offline  
Old 06-26-2022, 04:14 PM
  #6  
Registered
Thread Starter
 
Join Date: Jun 2022
Location: Norman, OK
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default

Two words.
CapnKirk323 is offline  
Old 06-26-2022, 04:15 PM
  #7  
Registered
Thread Starter
 
Join Date: Jun 2022
Location: Norman, OK
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default

Pics coming soon
CapnKirk323 is offline  
Old 06-26-2022, 04:42 PM
  #8  
Registered
Thread Starter
 
Join Date: Jun 2022
Location: Norman, OK
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default

More filler
CapnKirk323 is offline  
Old 06-26-2022, 04:42 PM
  #9  
Registered
Thread Starter
 
Join Date: Jun 2022
Location: Norman, OK
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default

This will take a bit.
CapnKirk323 is offline  
Old 06-26-2022, 04:43 PM
  #10  
Registered
Thread Starter
 
Join Date: Jun 2022
Location: Norman, OK
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default

Two more words.
CapnKirk323 is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.