Go Back  Offshoreonly.com > Owners Forum > Baja
30 Outlaw RPMs and Speeds >

30 Outlaw RPMs and Speeds

Notices

30 Outlaw RPMs and Speeds

Old 11-02-2021, 08:52 PM
  #1  
Registered
Thread Starter
 
Join Date: Jun 2007
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default 30 Outlaw RPMs and Speeds

I finally logged back in after 10 years from here and now I need some help. I just traded my 2006 23 outlaw that I bought new and picked up an 07 30 outlaw with 496 HOs. Paperwork and sticker on computer say HOs, but the motor cover plate was swapped out for a chrome one. That being said, with standard 26s on there, I am only pushing 46-4700 rpms at 66 mph GPS, trimmed out to 7-8 and zero on the tabs. Low fuel and 4 people. I was hoping the props were tweaked and bought a new set of labbed 28s since that seems like the consensus to run with these motors. Two people and virtually zero fuel, I hit 69 gps at 46-4700 rpms. Everything I have found says I should hit 5k. It seems like it may have the mag motors in there. Both motors run the exact same. It looks like the outdrives were separated before, and the tag on the outdrive is missing. Any ideas on what to check or do to see where my missing speeds/ RPMs could be? I thought I should be able to hit 75 fairly easy. I have trimmed out to about 10 where it start cavitating and RPMS did jump to about 4800, but I was not sure if I would do any damage if I trimmed any farther to see if I could hit 5k while over trimming
Outlaw Hawaan is offline  
Old 11-03-2021, 10:53 AM
  #2  
VIP Member
VIP Member
 
bencini231's Avatar
 
Join Date: Jul 2013
Location: Paducah,Ky
Posts: 326
Received 201 Likes on 81 Posts
Default

Originally Posted by Outlaw Hawaan View Post
I finally logged back in after 10 years from here and now I need some help. I just traded my 2006 23 outlaw that I bought new and picked up an 07 30 outlaw with 496 HOs. Paperwork and sticker on computer say HOs, but the motor cover plate was swapped out for a chrome one. That being said, with standard 26s on there, I am only pushing 46-4700 rpms at 66 mph GPS, trimmed out to 7-8 and zero on the tabs. Low fuel and 4 people. I was hoping the props were tweaked and bought a new set of labbed 28s since that seems like the consensus to run with these motors. Two people and virtually zero fuel, I hit 69 gps at 46-4700 rpms. Everything I have found says I should hit 5k. It seems like it may have the mag motors in there. Both motors run the exact same. It looks like the outdrives were separated before, and the tag on the outdrive is missing. Any ideas on what to check or do to see where my missing speeds/ RPMs could be? I thought I should be able to hit 75 fairly easy. I have trimmed out to about 10 where it start cavitating and RPMS did jump to about 4800, but I was not sure if I would do any damage if I trimmed any farther to see if I could hit 5k while over trimming
I had a issue with one of my 07 30 outlaws before not hitting the RPM's with 28p props on it. I changed the plugs, even though it only had 120hrs on it, the problem was solved. The old plugs didn't look bad, but the 496's are really funny at times with different things.
bencini231 is offline  
Old 01-06-2022, 02:06 PM
  #3  
Platinum Member
Platinum Member
iTrader: (1)
 
Join Date: Feb 2001
Location: Saugerties, NY
Posts: 588
Received 7 Likes on 6 Posts
Default

Originally Posted by Outlaw Hawaan View Post
I finally logged back in after 10 years from here and now I need some help. I just traded my 2006 23 outlaw that I bought new and picked up an 07 30 outlaw with 496 HOs. Paperwork and sticker on computer say HOs, but the motor cover plate was swapped out for a chrome one. That being said, with standard 26s on there, I am only pushing 46-4700 rpms at 66 mph GPS, trimmed out to 7-8 and zero on the tabs. Low fuel and 4 people. I was hoping the props were tweaked and bought a new set of labbed 28s since that seems like the consensus to run with these motors. Two people and virtually zero fuel, I hit 69 gps at 46-4700 rpms. Everything I have found says I should hit 5k. It seems like it may have the mag motors in there. Both motors run the exact same. It looks like the outdrives were separated before, and the tag on the outdrive is missing. Any ideas on what to check or do to see where my missing speeds/ RPMs could be? I thought I should be able to hit 75 fairly easy. I have trimmed out to about 10 where it start cavitating and RPMS did jump to about 4800, but I was not sure if I would do any damage if I trimmed any farther to see if I could hit 5k while over trimming
I have and 04 30 with 496 mags and I get 73 mph at 4600 rpms. I just recently sent out my props to bblades for some labbing to hopefully get a couple more mph. But to reiterate what Chris said. I also had a problem when trying to run higher rpms. I would even get a popping sound. I changed the plugs (the #7 plug had a hole in the porcelain) and it cleared everything up. Only had 140 hrs on it at the time.
FBRONCO is offline  
Old 01-12-2022, 10:23 AM
  #4  
Registered
 
Join Date: Jan 2005
Location: Katy, TX
Posts: 598
Received 10 Likes on 7 Posts
Default

i had a 2005 30 OL with HO's. Dont recall the props size, Im sure they were the standard issue and not worked on by the likes of BBlades, and could cruise at 78 all day long and hitting at or near 5000 rpm. Moderate fuel, 3-4 adults, gear etc. I do recall being told my boat had the X dimension raised though....
imartin is offline  
Old 01-12-2022, 11:08 AM
  #5  
Registered
iTrader: (2)
 
Join Date: Aug 2010
Location: Cape Coral FL
Posts: 1,805
Likes: 0
Received 162 Likes on 102 Posts
Default

Buddy of mine bought one brand new. It was a 72mph boat. It never ran any faster than that
snapmorgan is offline  
Old 01-12-2022, 12:05 PM
  #6  
VIP Member
VIP Member
 
bencini231's Avatar
 
Join Date: Jul 2013
Location: Paducah,Ky
Posts: 326
Received 201 Likes on 81 Posts
Default

2004 and 2005 had raised x dimensions. 2006-2008 did not.
bencini231 is offline  
The following users liked this post:
Jtime (01-13-2022)
Old 01-12-2022, 12:14 PM
  #7  
Platinum Member
Platinum Member
iTrader: (6)
 
F-2 Speedy's Avatar
 
Join Date: May 2012
Location: Midwest & T-Rock
Posts: 8,722
Received 1,420 Likes on 660 Posts
Default

Originally Posted by bencini231 View Post
2004 and 2005 had raised x dimensions. 2006-2008 did not.
was the 30 OL part of the delam liner boats, I know some of the 35's were
F-2 Speedy is offline  
Old 01-12-2022, 01:34 PM
  #8  
VIP Member
VIP Member
 
Join Date: Nov 2002
Location: ankeny,ia.
Posts: 3,890
Received 99 Likes on 60 Posts
Default

Originally Posted by F-2 Speedy View Post
was the 30 OL part of the delam liner boats, I know some of the 35's were
yes
JaayTeee is offline  
Old 01-12-2022, 01:49 PM
  #9  
VIP Member
VIP Member
 
bencini231's Avatar
 
Join Date: Jul 2013
Location: Paducah,Ky
Posts: 326
Received 201 Likes on 81 Posts
Default

Originally Posted by F-2 Speedy View Post
was the 30 OL part of the delam liner boats, I know some of the 35's were
The early ones were the only ones I've read about with issues. There was a old thread that said quite a few with issues were from LOTO. I've owned 6 of them and never had a single issue with any of the ones I've had. I will say the 04-05 30 OL's I had were faster than the 06-08 30 OL's. The 04 had 496 Mags and still ran 78 gps. The 05 had 496 HO's and hit 81 gps. Those #'s were with 2 people less than 1/2 tank and labbed 28 bravo 4 blades.
bencini231 is offline  
Old 01-12-2022, 03:13 PM
  #10  
Platinum Member
Platinum Member
iTrader: (6)
 
F-2 Speedy's Avatar
 
Join Date: May 2012
Location: Midwest & T-Rock
Posts: 8,722
Received 1,420 Likes on 660 Posts
Default

Bud of mine had a 08/09 Baja built 35 OL and it fell a part, Fountain at the time owned Baja ( 2010 ish ) Fountain built him a new boat 1 of just a few Fountain built 35 OL's w/525's

EDIT: no hijack to the OP
F-2 Speedy is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.