Go Back  Offshoreonly.com > Owners Forum > Cigarette
04 topgun. Fresh engines wonít prime >

04 topgun. Fresh engines wonít prime

Notices

04 topgun. Fresh engines wonít prime

Old 10-20-2019, 10:14 AM
  #1  
Registered
Thread Starter
 
Join Date: Jul 2013
Location: Miller Place, NY
Posts: 133
Received 2 Likes on 1 Post
Default 04 topgun. Fresh engines wonít prime

Just put two fresh 525s back in my topgun. For some reason they arenít getting fuel. Iím sure itís something stupid, but any input would be greatly appreciated.

boat has half tank of fuel
brand new fuel pumps
brand new everything actually lol
tdbrickndirt is offline  
Old 10-20-2019, 12:38 PM
  #2  
Registered
 
Join Date: Oct 2007
Location: Grand Haven, MI
Posts: 1,297
Received 9 Likes on 7 Posts
Default

Turn the key on and off about 10-12 times until your feel pressure doesn’t drop on the gauge. I’m guessing you just have some air in the line.
jbraun2828 is offline  
Old 10-20-2019, 12:54 PM
  #3  
Registered
Thread Starter
 
Join Date: Jul 2013
Location: Miller Place, NY
Posts: 133
Received 2 Likes on 1 Post
Default

Originally Posted by jbraun2828 View Post
Turn the key on and off about 10-12 times until your feel pressure doesnít drop on the gauge. Iím guessing you just have some air in the line.
Iíll give that a try. Thank you
tdbrickndirt is offline  
Old 10-20-2019, 01:28 PM
  #4  
Banned
 
Join Date: Oct 2019
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default

Both engines doing the same thing?
Offshore_Legend is offline  
Old 10-20-2019, 03:10 PM
  #5  
Registered
Thread Starter
 
Join Date: Jul 2013
Location: Miller Place, NY
Posts: 133
Received 2 Likes on 1 Post
Default

Originally Posted by Offshore_Legend View Post
Both engines doing the same thing?
technically no. Starboard electric field pump isnít coming on. Itís brand new but must be faulty. HS power to it

port engine pump comes on


ball valves are definitely open on fuel lines
tdbrickndirt is offline  
Old 10-21-2019, 07:41 PM
  #6  
Registered
 
Join Date: Nov 2014
Posts: 171
Received 17 Likes on 6 Posts
Default

Canít remember on the 525, is there a schrader valve on the rail? you can push down when you prime the pump? That would let you know that fuel is at the rail.
apex svt is offline  
Old 10-26-2019, 05:42 AM
  #7  
Registered
Thread Starter
 
Join Date: Jul 2013
Location: Miller Place, NY
Posts: 133
Received 2 Likes on 1 Post
Default

Thank you for your responses. Ended up needing new injectors. Good to go
tdbrickndirt is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


OSO Sponsor
OSO Advertiser
OSO Advertiser

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

OSO Advertiser