Go Back  Offshoreonly.com > Technical > Do It Yourself, Boating on a Budget
95 502 mag mpi topend noise at low rpms >

95 502 mag mpi topend noise at low rpms

Notices

95 502 mag mpi topend noise at low rpms

Old 05-26-2020, 12:59 PM
  #1  
Registered
Thread Starter
 
Join Date: Dec 2017
Location: Possum Kingdom
Posts: 44
Likes: 0
Received 0 Likes on 0 Posts
Default 95 502 mag mpi topend noise at low rpms

Just picked up a boat and that supposedly has low hours on head rebuilds plus all new manifolds and risers. Oil was very dark and thick before I tried starting it so first thing I did was change oil. Has fresh mobile 1 15w50 and a wix filter. Fired right up and runs fine but has a knocking noise coming from the top end that goes away above 1500 rpms. 40psi oil at idle and climbs to above 60 above 2500 rpms. Also , noise dosnt start until after engine is warm. Any ideas ?
jryotas is offline  
Old 05-26-2020, 02:52 PM
  #2  
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
Posts: 3,566
Received 298 Likes on 228 Posts
Default

Oil was very dark and thick
Hope something wasn't trying to be hidden

Tap lifter, knock rod
AllDodge is offline  
Old 05-26-2020, 05:03 PM
  #3  
Registered
Thread Starter
 
Join Date: Dec 2017
Location: Possum Kingdom
Posts: 44
Likes: 0
Received 0 Likes on 0 Posts
Default

Wouldnt either one still be present at 1500 rpms also ?
No noise at all above 1200 rpms . I read a different post about a guy who had a motor sit for a couple years and it make a noise similar to rod knock for about the first 45 mins of running , then went away.
Also read another thread about a guy who had very similar issue as mine and he had 2 different shops look at it and diag it as something different and never did get rid of the noise. Even after pulling motor to ck flex plate bolts, had the many other tests run and all good. He finally sold the boat.
jryotas is offline  
Old 05-26-2020, 05:11 PM
  #4  
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
Posts: 3,566
Received 298 Likes on 228 Posts
Default

Just a WAG, but cold oil, its thicker so lifter pumps up and for the most part stays there.

Oil warms up, thins out and lifter starts ticking.

RPMs come up, pressure increases and keeps lifter up

But you said it was a knock and not a tick

That old a motor, I would run dino oil with more zinc, but that's just me probably
AllDodge is offline  
Old 05-26-2020, 10:05 PM
  #5  
Registered
 
Join Date: Jun 2010
Posts: 4,138
Received 363 Likes on 167 Posts
Default

Lifters collapsing at low rpm..?
1MOSES1 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.