Go Back  Offshoreonly.com > Technical > Do It Yourself, Boating on a Budget
98 454 mag mpi starting issue >

98 454 mag mpi starting issue

Notices

98 454 mag mpi starting issue

Old 10-28-2021, 10:53 PM
  #1  
Registered
Thread Starter
 
Join Date: Sep 2021
Location: KY
Posts: 6
Received 0 Likes on 0 Posts
Default 98 454 mag mpi starting issue

Iíve been chasing this gremlin around all year long and finally need some adviceÖ.

I have narrowed it down to the circuit breaker box on top of he motor has a click when you hit the key. It feels like the Mercathode box is clicking. It would work great a few times out then youíd have to hit the key a few times with the click. I have replaced batteries, the solenoid in the box that looks like the trim one, checked connections, and tested all connections with a light. Iím stumped and hope someone can help out here!
Rde787 is offline  
Old 10-29-2021, 12:24 AM
  #2  
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 11,715
Received 1,367 Likes on 579 Posts
Default

Starting issue is no crank ?
SB is offline  
Old 10-29-2021, 06:22 AM
  #3  
Registered
Thread Starter
 
Join Date: Sep 2021
Location: KY
Posts: 6
Received 0 Likes on 0 Posts
Default

Originally Posted by SB View Post
Starting issue is no crank ?
it would click time to time but always fire up. Sounds like a starter but itís not clicking on the starter or solenoid itís in the box where the main circuit breaker is. Now just a click and nothing after
Rde787 is offline  
Old 10-29-2021, 08:27 AM
  #4  
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
Posts: 3,616
Received 321 Likes on 244 Posts
Default

Look in the box to see if you see the slave relay (can be one of 2 types). That is used to apply power to the starter solenoid


AllDodge is offline  
The following 2 users liked this post by AllDodge:
PA.WOODCHUCK (10-29-2021), Rde787 (10-29-2021)
Old 10-29-2021, 08:39 AM
  #5  
Registered
Thread Starter
 
Join Date: Sep 2021
Location: KY
Posts: 6
Received 0 Likes on 0 Posts
Default

[QUOTE=AllDodge;4810701]Look in the box to see if you see the slave relay (can be one of 2 types). That is used to apply power to the starter solenoid

I have replaced that twice, seems to me like itís clicking from the mercathode box. Iím unfamiliar with that system and maybe itís another box relay in there. Didnít know if anyone had this issue before or what I should look for/at.
Rde787 is offline  
Old 10-29-2021, 09:02 AM
  #6  
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
Posts: 3,616
Received 321 Likes on 244 Posts
Default

Originally Posted by Rde787 View Post

I have replaced that twice, seems to me like itís clicking from the mercathode box. Iím unfamiliar with that system and maybe itís another box relay in there. Didnít know if anyone had this issue before or what I should look for/at.
Could be you need to clean connections. Corrosion on a connection will not pass full voltage. Use a voltmeter and see what the voltages are prior to starting and while trying to. If voltage drops much at all then its corrosion or need a larger battery.
AllDodge is offline  
Old 10-29-2021, 09:10 AM
  #7  
Registered
iTrader: (1)
 
Join Date: Nov 2009
Location: KY
Posts: 3,616
Received 321 Likes on 244 Posts
Default

Start circuit
Corrosion anywhere along the line can cause the issue



AllDodge is offline  
The following users liked this post:
TomZ (10-29-2021)
Old 10-29-2021, 09:52 AM
  #8  
Registered
Thread Starter
 
Join Date: Sep 2021
Location: KY
Posts: 6
Received 0 Likes on 0 Posts
Default

Originally Posted by AllDodge View Post
Could be you need to clean connections. Corrosion on a connection will not pass full voltage. Use a voltmeter and see what the voltages are prior to starting and while trying to. If voltage drops much at all then its corrosion or need a larger battery.
ok, thanks! Thatís where I was headed next with it. Has 2 new 1000 cca batteries in it. Iíd think thatís plenty for a single 454 but who knows electric isnít my forte and thatís why Iím here asking lol
Rde787 is offline  
Old 10-29-2021, 10:27 AM
  #9  
SB
Registered
iTrader: (1)
 
Join Date: Nov 2004
Location: On A Dirt Floor
Posts: 11,715
Received 1,367 Likes on 579 Posts
Default

$10 the click from mercathode is actually from remote solenoid which is right next to it.

When it clicks (not starting) connect big posts of relay with screw driver or ? and see if cranks. If it does, itís typically the starter relay or itís ground or wire connections. If it doesnít itís typically the starter or itís wire connections.
SB is offline  
The following 2 users liked this post by SB:
Nothing personel 353 (10-29-2021), TomZ (10-29-2021)
Old 10-29-2021, 12:17 PM
  #10  
Registered
 
Join Date: May 2018
Location: Western Pennsylvanoa
Posts: 482
Received 76 Likes on 59 Posts
Default

Get a test light which any big box auto parts store should have which would make it easier to check your issue?
PA.WOODCHUCK is offline  

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.