Like Tree0Likes

Alpha no reverse

Reply

Old 05-24-2008, 07:41 PM
  #1
Charter Member #1055/Moderator
Charter Member
Thread Starter
iTrader: (1)
 
GO4BROKE's Avatar
 
Join Date: Feb 2001
Location: CNY
My Boat: Sonic 386
Posts: 4,582
Default Alpha no reverse

I have an alpha one, 1989, that was hard going into reverse for a season. I thought the cable was binding. The boat sat for 2 years , I just got around to getting it ready for water. Now it doesn't go in reverse at all. Cable works well, the little shift foot turns well, just doesn't go into gear. Forward is OK. When I changed the drive oil, It had about 1/4 qt hi perf lube, 1/2 qt water and nothing else. I guess it shifted hard due to no lube. After 2 years with water in it is it worth fixing or should I just buy a SEI lower for $700 and be done?
__________________
[img][/img]
GO4BROKE is offline  
Reply With Quote
Old 05-24-2008, 07:57 PM
  #2
Crazy Energy
Platinum Member
iTrader: (4)
 
Velocity Vector's Avatar
 
Join Date: Aug 2007
Location: Oklahoma God's country no one else wants it.
My Boat: Old Skool 35' Ocean Express Cat 1700 HP
Posts: 4,340
Default

I'd just fix it. I wouldn't spend a lot on a 89 alpha.
http://cgi.ebay.com/ebaymotors/Mercr...spagenameZWDVW

Last edited by Velocity Vector; 05-24-2008 at 08:07 PM.
Velocity Vector is offline  
Reply With Quote
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bstasch
Sonic
13
06-17-2008 10:40 AM
LostinBoston
General Q & A
5
07-01-2006 05:56 PM
Pure Energy
General Q & A
4
06-22-2004 08:47 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Quick Reply: Alpha no reverse


OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser