Go Back  Offshoreonly.com > Technical > Electronics
Mercury 525 trim tab help >

Mercury 525 trim tab help

Like Tree1Likes

Mercury 525 trim tab help

Reply

Old 06-06-2017, 05:16 PM
  #1
Registered
Thread Starter
 
Join Date: Sep 2013
Location: Wisconsin
My Boat: 2005 25 Outlaw
Posts: 953
Default Mercury 525 trim tab help

I need help getting my trim tabs to display on my Simrad GO9. Livorsi tabs with electronic senders wired to engine, engine smartcraft cable to vessel view link, vvl to nmea 2000 network and then to Simrad. Everything else from the engine displays just fine. The testing I've done suggests the signal is getting to the engine but is stopping there. Any help is appreciated.
IGetWet is offline  
Reply With Quote
Old 02-21-2019, 07:29 AM
  #2
Platinum Member
Platinum Member
 
30outlaw's Avatar
 
Join Date: Jun 2008
Location: Fond du Lac, WI
My Boat: 08 30 Outlaw 525/XR/ITS/SSM
Posts: 86
Default

ever get this figured out?
30outlaw is offline  
Reply With Quote
Old 02-21-2019, 08:05 AM
  #3
Registered
Thread Starter
 
Join Date: Sep 2013
Location: Wisconsin
My Boat: 2005 25 Outlaw
Posts: 953
Default

From what I’ve been suggested from Eddie Young and Dustin Whipple is that the firmware version of my motor probably doesn’t support the trim tab function. The motor I have is an earlier model 525, so that’s probably the issue. I really don’t need a tab indicator, go off of feel, but I’ll probably add a Livorsi LED indicator at some point.
IGetWet is offline  
Reply With Quote
Old 02-21-2019, 08:53 AM
  #4
VIP Member
VIP Member
 
VoodooRob's Avatar
 
Join Date: Jul 2011
Location: Cleveland Ohio
My Boat: 07 38 Lightning 600SCIs Stage 3
Posts: 1,857
Default

Originally Posted by IGetWet View Post
From what Iíve been suggested from Eddie Young and Dustin Whipple is that the firmware version of my motor probably doesnít support the trim tab function. The motor I have is an earlier model 525, so thatís probably the issue. I really donít need a tab indicator, go off of feel, but Iíll probably add a Livorsi LED indicator at some point.
IGetWet Were you able to get the trim from drive to show up on the Simrad?
VoodooRob is offline  
Reply With Quote
Old 02-21-2019, 09:04 AM
  #5
Registered
Thread Starter
 
Join Date: Sep 2013
Location: Wisconsin
My Boat: 2005 25 Outlaw
Posts: 953
Default

No. Seems the motor PCM firmware version doesn’t support the trim tab function. I even got the pin out of the PCM from mercury support and was able to confirm the signal from the tabs is going into the pcm.
IGetWet is offline  
Reply With Quote
Old 02-21-2019, 09:32 AM
  #6
VIP Member
VIP Member
 
VoodooRob's Avatar
 
Join Date: Jul 2011
Location: Cleveland Ohio
My Boat: 07 38 Lightning 600SCIs Stage 3
Posts: 1,857
Default

Originally Posted by IGetWet View Post
No. Seems the motor PCM firmware version doesn’t support the trim tab function. I even got the pin out of the PCM from mercury support and was able to confirm the signal from the tabs is going into the pcm.
My drives are not showing on my G05s. I talked to Mike at MDC thru email and he gave me some tips to try and if that doesnt work he can work some magic and get a signal from the Trim Sync I installed.

Last edited by VoodooRob; 02-21-2019 at 12:52 PM.
VoodooRob is offline  
Reply With Quote
Old 02-21-2019, 09:37 AM
  #7
Registered
Thread Starter
 
Join Date: Sep 2013
Location: Wisconsin
My Boat: 2005 25 Outlaw
Posts: 953
Default

Shoot, sorry misread your first post. Yes my drive trim displays on my simrad no problem.
IGetWet is offline  
Reply With Quote
Old 02-21-2019, 09:52 AM
  #8
Platinum Member
Platinum Member
iTrader: (5)
 
F-2 Speedy's Avatar
 
Join Date: May 2012
Location: Midwest & T-Rock
My Boat: F2 Speed racer
Posts: 5,805
Default

Mercury cant reflash the controller with updated firmware that will support it ? we do it all the time in my world
F-2 Speedy is offline  
Reply With Quote
Old 02-21-2019, 10:51 AM
  #9
Registered
Thread Starter
 
Join Date: Sep 2013
Location: Wisconsin
My Boat: 2005 25 Outlaw
Posts: 953
Default

Originally Posted by F-2 Speedy View Post
Mercury cant reflash the controller with updated firmware that will support it ? we do it all the time in my world
Not a computer thatís been reprogrammed by Whipple or any other aftermarket shop. Mercury has never came out and said anything about the firmware upgrade, so I think theyíre trying to keep it under the rug.
VoodooRob likes this.
IGetWet is offline  
Reply With Quote
Old 02-21-2019, 11:00 AM
  #10
Platinum Member
Platinum Member
iTrader: (5)
 
F-2 Speedy's Avatar
 
Join Date: May 2012
Location: Midwest & T-Rock
My Boat: F2 Speed racer
Posts: 5,805
Default

ya , I forgot it was whippled
F-2 Speedy is offline  
Reply With Quote

OSO Sponsor
OSO Advertiser
OSO Advertiser
OSO Advertiser