Like Tree0Likes

speedometer not functioning properly need advice

Reply
Old 01-30-2002, 02:50 PM
  #1
Registered
Thread Starter
 
Rambunctious's Avatar
 
Join Date: Jul 2001
Location: Holland, Mich
My Boats: 95 Formula 336 SR1 525SC's
Posts: 1,046
Post speedometer not functioning properly need advice

I have twin 454's with bravos. The speed"o" only reads 30mph at WOT. gps says 65. my mechanic said he found some debri in the water pickup when winterizing last season. still didn't fix the problem, probably still more debri....

Question: can I re-route the water pickup from the speedometer to the other drive. What does a typical manufacturere do with the other drive. Is there no hose? where can I find it. Do I need to pull the drive, or simply look in the right spot in the engine compartment for a plugged, or hanging hose? any advice would be appreciated.
Rambunctious is offline  
Reply With Quote
Old 01-30-2002, 03:03 PM
  #2
Charter Member#157
Charter Member
 
MnFastBoat's Avatar
 
Join Date: Oct 2000
Location: Minneapolis, Mn, Usa
My Boats: 1999 Advantage 28' Cat
Posts: 1,847
Post

The speedo hose starts first in the drive
When on the trailer and in travel position you should be able to reach in anc plug it in the other drive. Mine has a yellow plug that clips in. Then you will have to reroute the hose from the inside of the boat. There is a little hose barb on the inside transom mounting. It should be directly above the shaft. My port side is unplugged at the drive and capped at on the inside.
I got tired of blowing off my hose at the speedo in the dash at anyhing above 80
Always had to reach into the engine bay to unhook the hose. To lazy to get in the water.
Or you can do what I want to do and buy a GPS for the dash.
__________________
This Cat is trying to keep up with the Big Dogs
MnFastBoat is offline  
Reply With Quote
Old 01-30-2002, 04:40 PM
  #3
Tee
Guest
 
Posts: n/a
Post

Rambunctious,
I have the same problem, but I only have a single. I even went to a offshore pitot tube pickup and still my speedo is "Depressed" usually shows 15 - 25% lower than gps.
I need to look, maybe there is an adustment.?
Tee
 
Reply With Quote
Old 01-30-2002, 05:00 PM
  #4
Registered
Thread Starter
 
Rambunctious's Avatar
 
Join Date: Jul 2001
Location: Holland, Mich
My Boats: 95 Formula 336 SR1 525SC's
Posts: 1,046
Post

this is important Tee, because the passengers should NEVER see a speed that is less than reality I heard of a boat broker common trick is to drill the lower unit pickup "hole" a bit larger to show an "elevated" speed. don't know if it works.

I have GPS on my dash MNFastBoat, but passengers can't see it. they zero in on the large speedo stating 32mph. I would like to not have to explain to every new rider that...."yes it feels alot faster than 32mph. BECAUSE IT IS!!!! WE ARE GOING 65+ AND BURNING ALOT OF FUEL RIGHT NOW TO IMPRESS YOU!!!!.
I have my polebarn finished now and have a place finally to work on things. I'll probably do some look see'n this weekend. Thanks
Rambunctious is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
plumbers crack
General Boating Discussion
24
12-28-2005 10:16 PM
ssherman
General Boating Discussion
34
06-06-2002 07:34 PM
THE BULL
General Boating Discussion
5
05-29-2002 10:41 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:01 PM.


Copyright 2011 OffShoreOnly. All rights reserved.