Like Tree0Likes

Good marinas Sarasota?

Reply
Old 03-24-2006, 04:48 PM
  #1
Registered
Thread Starter
 
plumbers crack's Avatar
 
Join Date: Feb 2003
Location: bluffton sc
My Boats: 42 Outerlimits GTX
Posts: 1,516
Default Good marinas Sarasota?

I need a referral for a good mechanic in the sarasota area.My generator in the formula acts up and shuts down.I think its a bad sender(temp).We are coming into town for the poker run next week.It would be nice to have someone check it out while in the water.There are no mechanics that work on kohler gen sets near me in south carolina.Any help would be appreciated Thanks!
plumbers crack is offline  
Reply With Quote
Old 03-24-2006, 06:27 PM
  #2
Registered
 
Join Date: Oct 2002
Location: GUN LAKE MICHIGAN
My Boats: 1989 CARY 50
Posts: 80
Default Re: Good marinas Sarasota?

What year is your gen-set ? If its is your temp sender just unplug it (the temp sender that is) and see if it still acts up. It works on a grounding switch sender. It more than likely is a water pump problem if it runs for a while and then shuts down, if they don't move enough water the sensor will shut it down. Check the pump impeller and I'll bet you have a blade missing and is lodged in the line somewhere. Been there done that 2 summers ago. Chased it all summer cause I didnt get all the pieces of the impeller out of the lines after I installed a new one.
HOTROD2 is offline  
Reply With Quote
Old 03-24-2006, 07:16 PM
  #3
Registered
 
Join Date: Sep 2005
Location: Ft. Lauderdale, FL
My Boats: 1993 Reaction 32 C/C
Posts: 2
Default Re: Good marinas Sarasota?

There is a MarineMax dealer next to Mote Marine. The are a Mercury dealer and also Sea Ray, so I imagine they can work on generators. It is across the bay from the Hyatt basin. Their phone number is 941-388-4411.
reaction is offline  
Reply With Quote
Old 03-24-2006, 08:38 PM
  #4
Registered
Thread Starter
 
plumbers crack's Avatar
 
Join Date: Feb 2003
Location: bluffton sc
My Boats: 42 Outerlimits GTX
Posts: 1,516
Default Re: Good marinas Sarasota?

The gen is 2001 and has 10 hrs on it.The sea water pump seems to be pumping water.The discharge line is pumping water,and the hoses are cool to the touch.The temp guage in the cabin shows no temp reading at all.The gen will run almost 5 min then shuts down.After restart it will run maybe 2 min and then shut down.Like I said this gen has 10 hrs on it and I guess the impellor could have dried out and broken but,why no reading on the guage.Im assuming the sender/temp also controls auto shut down for high temp?I know this belongs in q&a but hey .any ckues guys?
plumbers crack is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Panther
General Boating Discussion
10
02-19-2009 10:09 AM
LubeJobs42
General Boating Discussion
14
06-06-2006 01:09 PM
Ryan Beckley
General Boating Discussion
55
12-12-2004 09:05 AM
way8up
General Boating Discussion
2
08-16-2003 08:01 PM
Formula Outlaw
General Boating Discussion
4
08-16-2003 04:50 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:45 AM.


Copyright 2011 OffShoreOnly. All rights reserved.