Like Tree0Likes

525 EFI overheating the oil?

Reply
Old 05-07-2006, 09:52 AM
  #1
Platinum Member
Platinum Member
Thread Starter
 
DRIVEN1's Avatar
 
Join Date: Dec 2005
Location: Apollo Beach, FL.
My Boats: 2005 Fountain 47 Lightning is gone.
Posts: 662
Default 525 EFI overheating the oil?

The center motor's oil is overheating? Noticed the belt was very loose, it would not even turn at idle. Changed out the belt and put in a new water impeller. The oil cooler is not blocked at all. The oil level is fine. It is still overheating the oil. Anyone already have something like this happen that could maybe save me some labor dollars when the mechanic comes over to check it out? I am hoping that it is something simple. Thanks Mike
DRIVEN1 is offline  
Reply With Quote
Old 05-07-2006, 11:23 AM
  #2
Registered
 
gsmith9898's Avatar
 
Join Date: Mar 2005
Location: tulsa, oklahoma
Posts: 1,870
Default Re: 525 EFI overheating the oil?

How is the oil pressure?
gsmith9898 is offline  
Reply With Quote
Old 05-07-2006, 11:47 AM
  #3
Platinum Member
Platinum Member
Thread Starter
 
DRIVEN1's Avatar
 
Join Date: Dec 2005
Location: Apollo Beach, FL.
My Boats: 2005 Fountain 47 Lightning is gone.
Posts: 662
Default Re: 525 EFI overheating the oil?

Quote:
Originally Posted by gsmith9898
How is the oil pressure?
Around 30 psi at 4000 rpm. The other motors are running around 40 psi at the same rpm.
DRIVEN1 is offline  
Reply With Quote
Old 05-07-2006, 11:53 AM
  #4
asg
VIP Member
VIP Member
 
Join Date: Jul 2004
Location: Fort Lauderdale
My Boats: 2007 Cigarette 39
Posts: 412
Default Re: 525 EFI overheating the oil?

providing there is nothing major mechanically going on change the oil filter as when it gets clogged the oil goes through the by-pass and then does not pass by the cooler.
asg is offline  
Reply With Quote
Old 05-07-2006, 12:07 PM
  #5
Platinum Member
Platinum Member
Thread Starter
 
DRIVEN1's Avatar
 
Join Date: Dec 2005
Location: Apollo Beach, FL.
My Boats: 2005 Fountain 47 Lightning is gone.
Posts: 662
Default Re: 525 EFI overheating the oil?

Quote:
Originally Posted by asg
providing there is nothing major mechanically going on change the oil filter as when it gets clogged the oil goes through the by-pass and then does not pass by the cooler.
I did not know that. I will do that next, hopefully that is all it is. Thank you Mike
DRIVEN1 is offline  
Reply With Quote
Old 05-07-2006, 12:50 PM
  #6
Registered
 
super termoli's Avatar
 
Join Date: Sep 2003
Posts: 647
Default Re: 525 EFI overheating the oil?

It might very well be what asg said. However, my experience with triple diesels is that the center engine will always run hotter and will generally use more oil. The center engine seems to be constantly experiencing a higher load factor.
super termoli is offline  
Reply With Quote
Old 05-07-2006, 01:14 PM
  #7
Registered
 
gsmith9898's Avatar
 
Join Date: Mar 2005
Location: tulsa, oklahoma
Posts: 1,870
Default Re: 525 EFI overheating the oil?

Just had the problem that asg said. Changed filter and that fixed the problem.
gsmith9898 is offline  
Reply With Quote
Old 05-07-2006, 02:38 PM
  #8
Platinum Member
Platinum Member
Thread Starter
 
DRIVEN1's Avatar
 
Join Date: Dec 2005
Location: Apollo Beach, FL.
My Boats: 2005 Fountain 47 Lightning is gone.
Posts: 662
Default Re: 525 EFI overheating the oil?

Quote:
Originally Posted by gsmith9898
Just had the problem that asg said. Changed filter and that fixed the problem.
Well I guess I will get a filter on Monday and try it. That would be great if a new filter would fix it.
DRIVEN1 is offline  
Reply With Quote
Old 05-07-2006, 03:24 PM
  #9
Registered
 
Join Date: Oct 2005
Location: Oshvegas WI
My Boats: Anything on the lot!
Posts: 520
Default Re: 525 EFI overheating the oil?

if you know for a fact that the oil is getting to hot then disregard, but have you checked your senders and guage wires?
JUKED YOU is offline  
Reply With Quote
Old 05-07-2006, 09:12 PM
  #10
Charter Member
Charter Member
Trade Score: (1)
 
Ted G's Avatar
 
Join Date: Jan 2001
Location: Edgerock Baby!!
My Boats: Marlago 35 FS, 18 Neptune CC
Posts: 7,661
Default Re: 525 EFI overheating the oil?

What temp are you running? My buddy's center motor runs the oil 10-20 hotter, but still never goes much over 220. If it was a salt water boat you may have deposits in the oil cooler that are restricting heat transfer, a good soak in CLR or muriatic acid should clear that right up.
__________________
Chesapeake Bay Powerboat Association
www.cbpba.com
Ted G is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gsmith9898
General Q & A
17
08-16-2012 11:14 AM
ROADHOG
General Q & A
1
07-03-2008 01:15 AM
gsmith9898
General Q & A
47
07-18-2006 10:38 AM
UNSANE
General Q & A
20
04-02-2006 11:48 AM
John B
General Q & A
3
02-17-2004 10:45 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:49 PM.


Copyright 2011 OffShoreOnly. All rights reserved.