Like Tree0Likes

Parts Assistance

Reply
Old 08-19-2006, 09:30 PM
  #1
Registered
Thread Starter
 
Join Date: May 2004
Location: Midlothian, VA
My Boats: Boatless :(
Posts: 615
Default Parts Assistance

Anyone know where I can get the rubber insert that goes into the rub rail? The rail itself is fine however, the rubber insert is covered in mold, etc from being covered without a vent. This is a for a 28' Nordic Heat...thanks.
Ca$hed Out is offline  
Reply With Quote
Old 08-19-2006, 09:45 PM
  #2
Registered
 
ratman's Avatar
 
Join Date: Oct 2004
Location: medellin colombia, pablo escobar's lil town
My Boats: michelob light scarab, sold, sailor now
Posts: 8,396
Default Re: Parts Assistance

try wiping it down with acetone it should clean it right up.
ratman is offline  
Reply With Quote
Old 08-20-2006, 01:20 AM
  #3
Registered
 
FASTERDAMITT's Avatar
 
Join Date: Jun 2002
Posts: 1,979
Default Re: Parts Assistance

Taco rub rails. Search the net.
FASTERDAMITT is offline  
Reply With Quote
Old 08-20-2006, 02:22 AM
  #4
Registered
Trade Score: (2)
 
Craney's Avatar
 
Join Date: Oct 2004
Location: Clayton NJ
My Boats: 28 Pantera 24 Python
Posts: 1,573
Default Re: Parts Assistance

I got mine from Trenton Marine (609)392-7275
Craney is offline  
Reply With Quote
Old 08-20-2006, 08:20 PM
  #5
Forum Regulator
VIP Member
Trade Score: (1)
 
Sydwayz's Avatar
 
Join Date: May 2001
Location: Worldwide
My Boats: 17' Speedliner Cat & O.P.B.
Posts: 21,920
Default Re: Parts Assistance

Shaw, definately wipe it down with Acetone. It cleans up REALLY nice.
Sydwayz is offline  
Reply With Quote
Old 08-20-2006, 08:31 PM
  #6
Registered
 
cosmic12's Avatar
 
Join Date: Jan 2006
Location: Syracuse N.Y.
My Boats: Dreaming of a 32 AT
Posts: 4,951
Default Re: Parts Assistance

Quote:
Originally Posted by Sydwayz
Shaw, definately wipe it down with Acetone. It cleans up REALLY nice.
ditto! works perfect!!! or call Lonnie @ nordic
cosmic12 is offline  
Reply With Quote
Old 08-21-2006, 08:18 AM
  #7
Member #154
Platinum Member
 
Indy's Avatar
 
Join Date: Oct 2000
Location: SW CT & Long Island Sound
My Boats: Missing my PowerPlay
Posts: 6,756
Default Re: Parts Assistance

Shawn...I used laquer thinner on it and it made it new again...never tried the acetone but it seems like either will work.
Indy is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MANITIE
General Racing Discussion
16
03-02-2005 06:34 PM
traviss
General Q & A
11
01-19-2003 10:12 PM
32fever
General Boating Discussion
9
07-08-2002 08:37 PM
Shane
General Q & A
1
06-17-2002 02:46 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:57 PM.


Copyright 2011 OffShoreOnly. All rights reserved.