Like Tree0Likes

volvo/penta ??s

Reply
Old 05-30-2007, 10:06 AM
  #1
Registered User
Gold Member
Thread Starter
 
bcfountain's Avatar
 
Join Date: Apr 2007
Location: prince george,va
My Boats: 27fountain/04waverunner/10meter
Posts: 1,476
Default volvo/penta ??s

my dad has a 26ft parker w/a volvo5700 engine....5.7 gmc.the motor would not start or run and he has traced the problem to the engine speed limenter,or over rev switch.he by-passed this switch and the boat runs great.he called around and tryed to locate the part but everybody said the part is no longer avalble.any help.thanks.
bcfountain is offline  
Reply With Quote
Old 05-31-2007, 06:48 PM
  #2
Registered
 
ToTheMax's Avatar
 
Join Date: Mar 2006
Location: 30,000 Islands Georgian Bay Ontario Canada
My Boats: ...sooner than I think...I hope...
Posts: 638
Default

That's surprising they wouldn't have the part. We have a '96 22 Mariah with a 5.8L Ford block, which they discontinued shortly after and we don't have any trouble getting parts for it. I'm assuming you went to an authorized Volvo Penta dealer?
ToTheMax is offline  
Reply With Quote
Old 06-01-2007, 11:39 AM
  #3
Diamond Member #001
Charter Member
Trade Score: (2)
 
C_Spray's Avatar
 
Join Date: Oct 2000
Location: Coastal North Carolina
My Boats: 2000 Formula 382 with Innovation 600's
Posts: 4,789
Default

Try Here. It's Volvo Penta's online store - they even have a section for older engines.
__________________
Retired! Boating full-time now.
C_Spray is offline  
Reply With Quote
Old 06-20-2007, 11:03 PM
  #4
Gold Member
Gold Member
Trade Score: (2)
 
spazboz's Avatar
 
Join Date: Dec 2006
Location: Zeeland, Michigan
My Boats: 26' Wellcraft Nova II, Wellcraft 210 Elite, PowerPlay 185 XLT
Posts: 1,150
Default engine speed limiter

I just had the SAME thing with my 1988 powerplay 230 conquest. After removing the speed limiter the boat ran great for about 2 days. Now for some reason I'm having trouble with poor top end performance and the engine surges at cruise speed. Has anyone else encountered this issue? The boat idles great and planes well yet, but shortly after bogs down badd.
spazboz is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sneekinfreek
Prop Talk
1
03-02-2010 11:31 AM
z.zuperboat
Drives and Lower Units
8
09-20-2007 09:41 AM
Payton
General Q & A
2
08-05-2004 07:39 PM
stevejohns
General Q & A
4
07-11-2003 12:10 PM
Lenwa
General Boating Discussion
2
09-09-2002 06:44 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:23 PM.


Copyright 2011 OffShoreOnly. All rights reserved.