Like Tree0Likes

GGB mufflers on N/A motors

Reply
Old 06-20-2007, 10:05 PM
  #1
Registered
Thread Starter
 
Tazz's Avatar
 
Join Date: Jun 2005
My Boats: Outerlimits 37 Quadstep, Hustler 377 Talon
Posts: 426
Default GGB mufflers on N/A motors

I put a pair of mufflers on my naturally aspirated 600cu in. 750/hp motors and it wiped 15mph off my top speed ! Is the fact that these motors are N/A and need to breath the issue? I figured i'd lose a few mph but nowhere near this much. As you can figure the mufflers are coming OUT tomorrow. Anybody else have any experience with this? BTW they are Stellings dry exhaust.
Tazz is offline  
Reply With Quote
Old 06-21-2007, 02:39 AM
  #2
Platinum Member
Platinum Member
Trade Score: (1)
 
articfriends's Avatar
 
Join Date: Jun 2004
Location: Frankenmuth
My Boats: EX 99 MPH 272 Baja owner, 1999 Scarab 33 AVS NOW
Posts: 6,072
Default

Wow ,I had exactly the opposite experience. My boat goes no faster or slower with them on (5" tails on stainless marine 3's with water added right at tip as it enters the muffler),Smitty
articfriends is offline  
Reply With Quote
Old 06-21-2007, 07:00 AM
  #3
VIP Member
VIP Member
 
wildthing357's Avatar
 
Join Date: Aug 2002
Location: Lake St Clair
My Boats: 37 Outerlimits
Posts: 603
Default

Let me know if you are going sell them. I lost one and have been looking for some for sale. I only lost 3 mph with mine.
wildthing357 is offline  
Reply With Quote
Old 06-21-2007, 02:01 PM
  #4
Registered
Thread Starter
 
Tazz's Avatar
 
Join Date: Jun 2005
My Boats: Outerlimits 37 Quadstep, Hustler 377 Talon
Posts: 426
Default

Did you try GGB ? 705-382-5275
Tazz is offline  
Reply With Quote
Old 06-21-2007, 06:28 PM
  #5
'05 Concept SF23
VIP Member
 
Join Date: May 2002
Location: Gladeville, TN
My Boats: 2006 Concept 23
Posts: 1,687
Default

I had no loss or gain with mine on a 600 CU IN EFI N/A. I love them. Running CMI's on the engines.
f311fr1 is offline  
Reply With Quote
Old 06-21-2007, 09:14 PM
  #6
Platinum Member
Platinum Member
 
Jassman's Avatar
 
Join Date: Oct 2000
Posts: 9,371
Default

Quote:
Originally Posted by f311fr1 View Post
I had no loss or gain with mine on a 600 CU IN EFI N/A. I love them. Running CMI's on the engines.
Who's motors do you have.
Jassman is offline  
Reply With Quote
Old 06-21-2007, 09:59 PM
  #7
I hate the winter!!
Platinum Member
 
Vinny P's Avatar
 
Join Date: Jul 2001
Location: long island, new york
My Boats: 99 checkmate 259
Posts: 2,707
Default

I have GGB extremes on my NA 540, 680 hp, running full dry CMI's. I noticed no speed loss at all. Unfortunetly, as far as I know, GGB is out of business.
Vinny P is offline  
Reply With Quote
Old 06-21-2007, 10:15 PM
  #8
Registered
Thread Starter
 
Tazz's Avatar
 
Join Date: Jun 2005
My Boats: Outerlimits 37 Quadstep, Hustler 377 Talon
Posts: 426
Default

GGB in NOT out of business, I posted the number above.

I am running 750 Cobras through Stellings dry exhaust.
Tazz is offline  
Reply With Quote
Old 06-21-2007, 10:42 PM
  #9
Registered
 
Join Date: Jan 2004
Location: Tennessee
Posts: 4,452
Default

Quote:
Originally Posted by Jassman View Post
Who's motors do you have.
ME,ME,ME.

Seriously, I put the mufflers on f311fr1's boat and was really impressed. The boat lost NO speed and they cut the noise in half. Would not hesitate to use them again.
Young Performance is offline  
Reply With Quote
Old 06-21-2007, 11:34 PM
  #10
VIP Member
VIP Member
Trade Score: (1)
 
Marginmn's Avatar
 
Join Date: Dec 2001
Location: Indianapolis, Lake Cumberland
My Boats: 38 Donzi ZRC, 29 Advantage XFlight
Posts: 3,472
Default

Have people had good success using the CMI sound elimination system mufflers? I'm about to put a set on my boat.
__________________
The Beak be gone
Marginmn is online now  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
greg bakker
General Q & A
7
04-10-2007 09:44 PM
greg bakker
General Boating Discussion
2
04-09-2007 09:09 PM
Attack
General Q & A
10
06-20-2006 08:59 PM
Fountainclimber
Fountain
2
07-06-2005 03:46 PM
GO4BROKE
General Q & A
3
01-16-2004 11:25 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:29 AM.


Copyright 2011 OffShoreOnly. All rights reserved.