Like Tree0Likes

525 EFI question?

Reply
Old 11-23-2007, 07:54 PM
  #1
Platinum Member
Platinum Member
Thread Starter
 
Full Throttle 525's Avatar
 
Join Date: Sep 2003
Location: Milford, CT
Posts: 1,101
Default 525 EFI question?

Okay:

I have a single 525 EFI with about 300 hours on the engine and drive. Everything seems to run fine, with the exception of some minor part failures. At what point should I start thinking about doing something before something happens? And what should that something be?
Thanks in advance for the response(s).

Ron
Full Throttle 525 is offline  
Reply With Quote
Old 11-23-2007, 09:43 PM
  #2
Charter Member #1055/Moderator
Charter Member
Trade Score: (1)
 
GO4BROKE's Avatar
 
Join Date: Feb 2001
Location: CNY
My Boats: Sonic 386
Posts: 4,579
Default

Quote:
Originally Posted by Pantera28-650HP View Post
Hey Ron -

I'm sure some more experienced Merc guys will chime in, but I would recommend at least a top end rebuild by now, springs and the valve train are really the only thing that should need to be addressed.

A leak down and compression check should give you an indication of the health of the engine.

Better to do the heads now than loose a spring or retianer and drop a valve. Cheap insurance.

Have a great weekend,

Kirk
Sounds like good advice to me.
__________________
[img][/img]
GO4BROKE is offline  
Reply With Quote
Old 11-24-2007, 04:48 AM
  #3
Charter Member # 55
Charter Member
 
Griff's Avatar
 
Join Date: Oct 2000
Location: Omaha
My Boats: .......32............. ...............Active Thunder....
Posts: 15,741
Default

Agreed also. Spend 2 grand soon to avoid a major failure later. Valve job, springs and lifters.
Griff is offline  
Reply With Quote
Old 11-24-2007, 08:56 AM
  #4
VIP Member
VIP Member
 
JIMKID Motorsports's Avatar
 
Join Date: Mar 2001
Location: Livonia Mi Usa
My Boats: 2009 30 LS7 SKATER 711 sold xvi power
Posts: 1,912
Default

kirk hit the nail on the head ha ha no seriosly thats what i would do
__________________
30 SKATER LS7
JIMKID Motorsports is offline  
Reply With Quote
Old 11-24-2007, 01:51 PM
  #5
Registered
 
Join Date: Jan 2004
Location: San Diego, California
Posts: 2,777
Default

Couln't agree more!

Ray @ Raylar
Raylar is offline  
Reply With Quote
Old 11-24-2007, 03:17 PM
  #6
Gold Member
Gold Member
Trade Score: (2)
 
Pwrbt33's Avatar
 
Join Date: Jan 2001
Location: Curtis Bay, Md USA
Posts: 2,122
Default

YUP, good advice!
Pwrbt33 is offline  
Reply With Quote
Old 11-24-2007, 03:50 PM
  #7
VIP Member
VIP Member
 
lucky strike's Avatar
 
Join Date: Sep 2003
Location: Pompano Beach, Florida
My Boats: Using LS JR. TG
Posts: 8,467
Default

Leak down & new headers.

LS
__________________
www.mercedeshowroom.com
lucky strike is offline  
Reply With Quote
Old 11-24-2007, 04:58 PM
  #8
Platinum Member
Platinum Member
Thread Starter
 
Full Throttle 525's Avatar
 
Join Date: Sep 2003
Location: Milford, CT
Posts: 1,101
Default

Thanks Guys...appreciate all your help. I'll get right on it.

Ron
Full Throttle 525 is offline  
Reply With Quote
Old 12-25-2007, 03:20 PM
  #9
Platinum Member
Platinum Member
Thread Starter
 
Full Throttle 525's Avatar
 
Join Date: Sep 2003
Location: Milford, CT
Posts: 1,101
Default

Okay: I had a faulty crank shaft sensor and had a throttle response adjusted. Now I can't seem to get the RPM's to 5250with my 24 B1 prop where I used to almost hit the rev limiter with it before. Any quick thoughts?

Ron
Full Throttle 525 is offline  
Reply With Quote
Old 12-25-2007, 03:26 PM
  #10
Charter Member #1171
Charter Member
 
obnoxus's Avatar
 
Join Date: Feb 2001
Location: New Lenox , Il
My Boats: 2000 36 OUTLAW SOLD SHOPPING
Posts: 3,913
Default

throttle responce adjusted?

Have you touched the cables lately?

Make sure you are getting WOT.

Second would be make sure its the correct sensor, and check timing.
__________________
IF YOUR UNDER CONTROL,,,,,YOUR NOT GOING FAST ENOUGH !!!!
obnoxus is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ted G
General Q & A
7
08-14-2006 08:49 AM
gsmith9898
General Q & A
8
10-20-2005 03:25 PM
2112
General Q & A
5
03-07-2004 06:30 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:33 PM.


Copyright 2011 OffShoreOnly. All rights reserved.