Like Tree0Likes

West Palm Boating, Sunday Feb. 10??

Reply
Old 02-10-2008, 06:23 PM
  #41
Registered
 
Pantera24's Avatar
 
Join Date: Aug 2001
Location: Miami,Fl.
My Boats: 1978 Pantera 24'
Posts: 1,757
Default

DAMN Rick !! Talk about a crappy day....

Dude if there is anything I can do to help ya out please let me know.

Angel
Pantera24 is offline  
Reply With Quote
Old 02-10-2008, 06:40 PM
  #42
Registered
 
bouyhunter's Avatar
 
Join Date: Aug 2002
Location: Apache Jct. AZ
My Boats: 24' Pantera
Posts: 5,646
Default

Damn Rick - rough day on the water.
I've dunked more than one cellphone.
Lost prop nut and washer in the drink.
And I was racing a guy, turned to look over my shoulder to make sure I was clear, and watched a pair of sunglasses that I owned for 6 hrs bounce off the sunpad into the drink.

BUT I DIDN'T DO IT ALL IN THE SAME DAY!!!!
bouyhunter is offline  
Reply With Quote
Old 02-10-2008, 08:16 PM
  #43
Registered
 
Join Date: Aug 2007
Location: Boynton Beach, FL
My Boats: 1998 Scarab 22'
Posts: 159
Default

So, after being beached like a whale at Peanut Island today, we managed to get underway at about 4PM... 3 or 4 minutes into the trip I notice the temp gauge creeping up, followed shortly thereafter by the alarm... cut the motor, jumped in the water to make sure nothing was plugging the water inlet holes -- all clear. Back on board, pop the engine hatch, sea pump feels cool, not like a burnt up impeller, no screeching from it when the motor is running.

Let it sit for a few minutes, restarted, and it ran relatively cool at idle -- a little warmer than usual (165 or so, instead of 155 as usual), but it was stable. Temp stayed steady up to 1400 rpm, but anything over that, the temp shot upwards... Took us 3 hours to get back to the Boynton ramp from Peanut.

The channel leading to the ramp was so shallow I had to have my passengers sit on the deck to take weight off the stern, to keep the drive from hanging up.

Anyway, I'm guessing I sucked up some sand and stuff today, and either screwed up the impeller, clogged a hose somewhere, or got a bunch of sand in the block (hoping not).

I figure I'll tear apart the cooling system, new impeller, new thermostat, flush whatever I can... any other thoughts?

What a day... at least it was a great run on the way up, it was fun meeting some new faces! Hope everyone else got home OK!
DrFeelgood is offline  
Reply With Quote
Old 02-10-2008, 08:36 PM
  #44
Charter Member #927
Charter Member
 
Payton's Avatar
 
Join Date: Jan 2001
Location: IN
My Boats: 1991 34' Super Hawaii
Posts: 4,817
Default

Sorry to hear about you guys troubles, but look on the bright side. We had -25 degree wind chill all day.
Payton is offline  
Reply With Quote
Old 02-11-2008, 04:54 AM
  #45
Platinum Member
Platinum Member
 
Xray50's Avatar
 
Join Date: Oct 2003
Location: Boca Raton Florida
My Boats: 96 AO 26'
Posts: 478
Default

The saga doesn't end there!
Left Dr Feel Good and Barry at the sandbar. After getting grounded acouple of times, made it out to the channel. Heard the nasty telltale squeal of the impeller frying. Temp gauge went to 220! Pulled sea pump. All blades and pieces had are in the engine someplace. Called SeaTow and got towed back.
3 hours later back at Knowles!
Story doesn't end here! It's low tide!
Backed the trailer in and it dropped of the end of the ramp. Had to rig a makeshift winch with my tiedown straps hooked to the dock to lift the ass end of the trailer back up on the ramp.
Pete's $100 sunglasses in the water.
Got home at 8:30! Other than that had a good time.
Pleasure meeting DrFeelGood and Barry.
Xray50 is offline  
Reply With Quote
Old 02-11-2008, 07:14 AM
  #46
Registered
Thread Starter
Trade Score: (1)
 
rchevelle71's Avatar
 
Join Date: Aug 2003
Location: Boca Raton
My Boats: 1982 Pantera 24sport
Posts: 7,392
Default

HOLY CRAP!!!!

Well, at least my phone was insured, and the pull back from towboat went fine for me, Jason had brought sandwiches, and I had a full cooler of beer, and the tunes still worked. At least we avoided that ticket, but it was quite embarassing to get towed back by the marina where I swapped the prop. the gas girl was standing out there laughing as we got towed by.

As far as my motor, no spark on any cylinders, I think I may have fried the ECU, or a feed wire came off(unlikely), but it was acting as if one of the killswitches were pulled. My only REAL Loss was Jasons glasses, they werent sunglasses, but his everyday glasses, he was blind as a bat, good thing he works from home, and doesnt live far from my house where his truck was.

Sorry for everyones troubles, I hope Barry had a good day at least after towing down from Orlando.

Rick
rchevelle71 is offline  
Reply With Quote
Old 02-11-2008, 07:19 AM
  #47
Registered
 
Join Date: Aug 2007
Location: Boynton Beach, FL
My Boats: 1998 Scarab 22'
Posts: 159
Default

Pretty much a cursed day from the onset, I guess -- Hopefully Barry and family got back safely -- I didn't see them stuck in the crappy Boynton channel, at least!

Sorry to hear about your impeller, Ray. I'm gonna tear mine down one night this week and see if mine is full of sand.

At least nobody got hurt
DrFeelgood is offline  
Reply With Quote
Old 02-11-2008, 07:38 AM
  #48
Registered
Thread Starter
Trade Score: (1)
 
rchevelle71's Avatar
 
Join Date: Aug 2003
Location: Boca Raton
My Boats: 1982 Pantera 24sport
Posts: 7,392
Default

Quote:
Originally Posted by DrFeelgood View Post
Pretty much a cursed day from the onset, I guess -- Hopefully Barry and family got back safely -- I didn't see them stuck in the crappy Boynton channel, at least!

Sorry to hear about your impeller, Ray. I'm gonna tear mine down one night this week and see if mine is full of sand.

At least nobody got hurt
Andrew, make sure you backflush the oil coller.
rchevelle71 is offline  
Reply With Quote
Old 02-11-2008, 07:52 AM
  #49
Platinum Member
Platinum Member
 
Xray50's Avatar
 
Join Date: Oct 2003
Location: Boca Raton Florida
My Boats: 96 AO 26'
Posts: 478
Default

I have to back flush everything also. All but one chunk of impeller is in the system someplace!!!!
Xray50 is offline  
Reply With Quote
Old 02-11-2008, 08:35 AM
  #50
Platinum Member
Platinum Member
 
Xray50's Avatar
 
Join Date: Oct 2003
Location: Boca Raton Florida
My Boats: 96 AO 26'
Posts: 478
Default Pics from Sunday

A couple of pics....
Attached Thumbnails
West Palm Boating, Sunday Feb. 10??-p2101383.jpg   West Palm Boating, Sunday Feb. 10??-p2101385.jpg   West Palm Boating, Sunday Feb. 10??-p2101387.jpg  

Xray50 is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Maritime_Eng
Ft Myers Offshore
4
02-22-2008 07:24 AM
ThoroughHustler
General Boating Discussion
7
02-09-2008 10:29 PM
rchevelle71
General Boating Discussion
10
10-07-2007 07:39 PM
STRAIGHTPRIORITY
General Boating Discussion
12
10-01-2007 02:10 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:29 PM.


Copyright 2011 OffShoreOnly. All rights reserved.