Like Tree0Likes

Speedo Trouble Please Help

Reply
Old 06-24-2008, 12:15 PM
  #1
Registered
Thread Starter
 
Join Date: Feb 2008
Posts: 140
Default Speedo Trouble Please Help

My speedometer has always worked fine. It is nothing fancy just the old pressure style with one rubber line going to it from the water with the pickup on the rear of the boat. I put in a new steering cable recently and was anchored in shallow water so I'm not sure which or both contributed to my speedo not working but it doesn't work anymore. I noticed I accidentally kinked the line where it goes into the back of the speedo so I thought that was it but after fixing it it still doesn't work. If I remove the line from the rear of the speedo I can blow through the line but there seems to be quite a bit of resisitance. I ran the boat in the lake with the line off the back of the speedo and no water comes out? Shouldn't it? I can't figure out what is wrong with this thing and I feel kind of dumb because its such a simple setup.
CenturyUltra is offline  
Reply With Quote
Old 06-24-2008, 12:32 PM
  #2
Registered
 
PorscheSpeed's Avatar
 
Join Date: Aug 2003
Location: Catawba Island, Ohio
My Boats: Cigar Top Gun
Posts: 474
Default

Maybe the Pitot tube on the transom is plugged? Try cleaning it out with a coat hanger or piece of wire.
PorscheSpeed is offline  
Reply With Quote
Old 06-25-2008, 12:46 AM
  #3
Charter Member # 55
Charter Member
 
Griff's Avatar
 
Join Date: Oct 2000
Location: Omaha
My Boats: .......32............. ...............Active Thunder....
Posts: 15,742
Default

Its clogged at the pick up on the drive.
Griff is offline  
Reply With Quote
Old 06-25-2008, 02:47 AM
  #4
Registered
 
Join Date: Jul 2005
Location: Boyne City, Michigan
My Boats: 2002 Baja 25 Outlaw
Posts: 412
Default

If you can't blow through it i'd say it's plugged. Mine went out last year and it took me several trys to get it fixed. I cleaned the holes, checked the joints in tubes, blah blah blah. nothing. i take the guage out and hit it with super low air pressure and it works. so i decided to drain the old fluid out and refill while it was out. anyways, something musta been up with the needle cuz it worked after that.
BUT- a month or so later it stopped again! I found a slice about 1 inch long in the tube replaced and worked.
THEN- about 1 week later, it stopped again so i checked the tube and found it had exploded. literally! you could plainly see where an air pocket formed in the line and caused major stretching and expansion before the line finally gave.
SO- i replaced that just this spring, worked great for about 5 mins and the joints seperated.
TODAY- plugged them back together, re-clamped...2 mins after running they seperated again!!!!!!!!!!!! i'm gonna lose my mind soon. anyone got a suggestion for ME? lol
Freeryd is offline  
Reply With Quote
Old 06-25-2008, 07:14 AM
  #5
Registered
 
Join Date: May 2007
Location: Akron, OH
My Boats: Open Slip - formerly Formula'd
Posts: 624
Default

GPS speedo. Leaves less money for drinking, I know--but....
BlackJack58 is offline  
Reply With Quote
Old 06-25-2008, 07:31 AM
  #6
Platinum Member
Platinum Member
 
Jassman's Avatar
 
Join Date: Oct 2000
Posts: 9,371
Default

I hear David Richard is an expert in speedo's..you might want to give him a call...
Jassman is offline  
Reply With Quote
Old 06-25-2008, 08:06 AM
  #7
Registered
Thread Starter
 
Join Date: Feb 2008
Posts: 140
Default

If I remove the line from the back of the speedo it should push water out of it when I am running the boat down the lake correct? I can blow through it with my mouth but there is a lot of restriction. I should be able to blow through it freely?
CenturyUltra is offline  
Reply With Quote
Old 06-26-2008, 02:03 AM
  #8
Registered
 
Join Date: Jul 2005
Location: Boyne City, Michigan
My Boats: 2002 Baja 25 Outlaw
Posts: 412
Default

freely is a bit much i think....you gotta remember, you're trying to blow air through that tiny tube all the way back to your drive. how many twists and turns does it take? more then you think, and ANY bends make it that much harder.
what have you checked so far?
and as for water coming out while running, i dunno bro. hopefully someone with more knowledge will help ya. i was just gettin this back to the front page for ya! lol
Freeryd is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fountainfevr
Fountain
2
04-03-2008 08:25 PM
carrboy
General Q & A
9
03-16-2007 07:47 PM
Zoom3
Baja
0
12-09-2004 01:09 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:58 AM.


Copyright 2011 OffShoreOnly. All rights reserved.