Like Tree0Likes

Good News! SB engine mystery solved

Reply
Old 11-13-2008, 06:45 PM
  #1
Registered
Thread Starter
 
Join Date: Dec 2003
Location: Raleigh,NC & 1000 Islands,NY
My Boats: 99' AT28twin, 2004 Starcraft, 1978 Switzer
Posts: 1,024
Default Good News! SB engine mystery solved

Some of you may remember my previous posts with regards to my 99AT w/350magMPI's....I had overheated during the Jammin on the James PR and had experienced some minor engine noise(ticking, knocking) after changing the sea water pumps & running for several hours. Well, I believe I have found the problem to be a minor gasket leak between the Stainless Marine exhaust manifold and the head. After speaking with a few engine guys about upgrades and my options, I got some help from a source in S.FL and he was right! Thanks Ron P.; what a relief....
Thanks everyone for chiming in......
BTW, I'm keeping the engines stock and spending the $$ on Imco full hydraulic external steering.
Spilman out.....
spilman is offline  
Reply With Quote
Old 11-13-2008, 06:52 PM
  #2
Registered User
 
Join Date: Jan 2007
Location: Mansfield, TX
My Boats: 1990 28 Apache SOLD!, 1990 16 Wahoo DC, 1973 40 Kingscraft
Posts: 5,701
Default

Good news, wish my engine woes would have been that small.
TexomaPowerboater is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Reckless32
General Q & A
13
06-27-2007 02:47 PM
wantsa311
Formula
2
07-12-2005 12:02 PM
Chris288
General Boating Discussion
5
04-08-2003 07:41 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:20 AM.


Copyright 2011 OffShoreOnly. All rights reserved.