Like Tree0Likes

Fuel pres. for a 496 mag.

Reply
Old 02-06-2009, 05:24 PM
  #1
Registered
Thread Starter
 
Join Date: Apr 2003
Location: Punta Gorda
My Boats: new to me 388 slingshot 2000 velocity 390 sold 2005 390 velocity sold 2001 390 velocity sold 260 velocity sold 320 velocity sold 30ft velocity sold vr1 velocity sold 35 Cigarette sold. 34 phantom cur.
Posts: 1,789
Default Fuel pres. for a 496 mag.

What should the fuel pres. be on a 496 mag? What should it be under load?
Velocity Tom is offline  
Reply With Quote
Old 02-07-2009, 04:18 PM
  #2
Registered
 
Join Date: Jan 2004
Location: San Diego, California
Posts: 2,777
Wink

43-45 psi key on engine not running. Should be stable at idle again between 43-45 psi with vacume line disconnected and plugged. At WOT, it should not drop below 41-43 psi.

Best Regards,
Ray @ Raylar
Raylar is offline  
Reply With Quote
Old 02-08-2009, 07:54 PM
  #3
Registered
Thread Starter
 
Join Date: Apr 2003
Location: Punta Gorda
My Boats: new to me 388 slingshot 2000 velocity 390 sold 2005 390 velocity sold 2001 390 velocity sold 260 velocity sold 320 velocity sold 30ft velocity sold vr1 velocity sold 35 Cigarette sold. 34 phantom cur.
Posts: 1,789
Default

We have 40 psi.at idle and when you crack the throt. it drpos to 36 psi
Velocity Tom is offline  
Reply With Quote
Old 02-08-2009, 11:29 PM
  #4
Registered
 
Join Date: Jan 2004
Location: San Diego, California
Posts: 2,777
Wink

You most likely either have one of three scenarios:
1. a problem with a fuel pump-most likely clogged inlet screen.
2. a fuel water seperator filter that is clogging or contaminated.
3. a fuel pressure regulator that is going bad.
Check these items and you will probably find one is the culprit.
good Luck,
Ray @ Raylar
Raylar is offline  
Reply With Quote
Old 02-09-2009, 06:07 PM
  #5
Registered
Thread Starter
 
Join Date: Apr 2003
Location: Punta Gorda
My Boats: new to me 388 slingshot 2000 velocity 390 sold 2005 390 velocity sold 2001 390 velocity sold 260 velocity sold 320 velocity sold 30ft velocity sold vr1 velocity sold 35 Cigarette sold. 34 phantom cur.
Posts: 1,789
Default

Its my friends boat and he let it sit for a few months. And when he went to run it all the filters were cloggd with black particles. All the fuel lines were decying. Ethenol I guess
So the elec. fuel pump has a inlet screen.
Ill bet its pluged to. Whre is the screen?
Velocity Tom is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Keith Atlanta
General Q & A
4
11-07-2008 11:36 PM
496mag
General Boating Discussion
18
03-11-2008 02:57 AM
TeamPSI
General Q & A
23
12-10-2007 06:23 PM
dan252
Drives and Lower Units
1
07-02-2007 11:01 PM
Strip Poker 388
General Q & A
1
07-08-2003 01:03 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:20 PM.


Copyright 2011 OffShoreOnly. All rights reserved.