Like Tree0Likes

Merc 525 help???

Reply
Old 04-20-2009, 12:52 PM
  #21
Charter Member
Charter Member
 
Thunderstruck's Avatar
 
Join Date: Nov 2000
Location: Lake Charles, LA USA
My Boats: 1998 32' Active Thunder (Sold)
Posts: 1,094
Default

Quote:
Originally Posted by THLWL View Post
But you also need to check and make sure it's not just a weak or broken valve spring or faulty lifter which would still cause a popping sound and also allow for a good compression check reading. Believe me, I've been down this road for the last 3 years.
Tommy, did you perform compression or leak downs during this time?? Just wondering what results you got.
__________________
Long time cult member.
Thunderstruck is offline  
Reply With Quote
Old 04-20-2009, 02:16 PM
  #22
Registered
 
Join Date: Jul 2001
Location: Pomona,ca
My Boats: 38' Scarab P-38
Posts: 482
Default

A flat cam will cause popping through the intake.(I know 525 efis' have roller cams). It won't always show up in a compression test (cranking). You loose lift (and duration) on the exhaust valve, then the exhaust charge cannot fully evacuate from the cylinder, then it compresses and pops throught the intake when that valve opens next. More promenent at high rpm obviously. Pull the valve cover crank the motor (fuel disabled) and watch the rockers. Good luck
Michael Garibay is offline  
Reply With Quote
Old 04-20-2009, 02:35 PM
  #23
Registered
 
txriverrat2001's Avatar
 
Join Date: Jan 2004
Location: Channelview, Texas
My Boats: 1993 Cruisers Inc Twin Diesel, 23' CC 225 Optimax
Posts: 911
Default

Quote:
Originally Posted by THLWL View Post
Good luck is all I can say. My popping sound was stuck valves in head. I've stuck the exhaust valves in the heads for the third year in a row and am still under 200 hours on engines. NO ONE can find the culprit. I've now had the heads rebuilt by the third diff shop. Merc Racing has been no help. I originally had capt call exhaust and they blamed it on that. The last 2 years, I've had Merc original exhaust and still sticking. We've done it all to the heads - enlarged tolerances, etc. Hope your prob is not with the valves sticking cause IT SUCKS! BTW, if the popping sounds like it's thru the intake (like mine), it can be an indication the exhaust valve not opening properly to let out fired exhaust. And 5400 on RPM's, my rev limiter alarm goes off at about 5100.

So how did it run this weekend??
txriverrat2001 is offline  
Reply With Quote
Old 04-20-2009, 05:25 PM
  #24
Gold Member
Gold Member
 
Join Date: Jan 2004
Location: Houston, Texas
My Boats: 34 Fountain trip 300's
Posts: 491
Default

Quote:
Originally Posted by txriverrat2001 View Post
So how did it run this weekend??
Great! No issues.
THLWL is offline  
Reply With Quote
Old 04-21-2009, 08:14 AM
  #25
Registered
Thread Starter
 
Join Date: Sep 2008
Posts: 48
Default

I am gonna take the heads off this and ill get back with u guys on whats wrong..
vinnysrt8 is offline  
Reply With Quote
Old 04-22-2009, 04:39 PM
  #26
Gold Member
Gold Member
 
Join Date: Jan 2004
Location: Houston, Texas
My Boats: 34 Fountain trip 300's
Posts: 491
Default

Quote:
Originally Posted by vinnysrt8 View Post
I am gonna take the heads off this and ill get back with u guys on whats wrong..
Keep us posted. I'm interested in outcome. Hoping for the best for you like a cracked plug, wire loose, valve spring, etc. The electronic control system is extensive also. Also, have you replaced the mechanical fuel pump since 04? Just thinking of everything I've done. Tommy (Btw, they may move this engine thread to the technical forum area like they did on mine)
THLWL is offline  
Reply With Quote
Old 04-22-2009, 10:15 PM
  #27
Registered
Thread Starter
 
Join Date: Sep 2008
Posts: 48
Default

no i didnt change the mechanical fuel pump b/c it is showing a steady 40 pounds.
vinnysrt8 is offline  
Reply With Quote
Old 04-22-2009, 10:23 PM
  #28
Registered
 
Join Date: Oct 2002
Location: New Orleans,La.
My Boats: '87 Kevlar Cig Top Gun,24 ft party barge"BaDaBoom"
Posts: 981
Default

When you did the tune up,did all the plugs look the same or was one or more different?If a valve was stuck open and hit the piston,compression would be low (or 0) in that cyl.I'd check that ign system like Mr Young suggested.
Bob280Silencer is offline  
Reply With Quote
Old 04-23-2009, 09:22 PM
  #29
Registered
Thread Starter
 
Join Date: Sep 2008
Posts: 48
Default

when i did the tune up all the plugs looks good........
vinnysrt8 is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:10 AM.


Copyright 2011 OffShoreOnly. All rights reserved.