Like Tree0Likes

1996 Mercruiser 7.4 Still No Spark

Reply
Old 04-26-2009, 02:17 AM
  #1
Registered
Thread Starter
 
Join Date: Apr 2009
Posts: 110
Default 1996 Mercruiser 7.4 Still No Spark

Help anyone i have replaced the primary coil the coil in the distrubotore and the module ,checked for 12 volts at the coil and its good but the spark out of the coil is very weak to the distrubitor doesnt jump a gap at all , it has 12 volts to the coil , any help would be appericated , thanks james , wondering maybe if the main brain is bad at this point.
jimmie is offline  
Reply With Quote
Old 04-26-2009, 02:23 AM
  #2
Charter Member # 55
Charter Member
 
Griff's Avatar
 
Join Date: Oct 2000
Location: Omaha
My Boats: .......32............. ...............Active Thunder....
Posts: 15,748
Default

What ignition do you have??? There is only one coil in all of them.

Check the connection that plugs into the ignition module. If the ignition module is bolted to the riser, unbolt it and clean the surfaces on the riser and module bracket. The module grounds through the bracket as well as the black wire.

Does the engine not fire or what????????
Griff is offline  
Reply With Quote
Old 04-26-2009, 02:50 AM
  #3
Registered
 
Join Date: Mar 2009
Posts: 496
Default

Do you have a service manual from merc on this engine yet? Also try unhooking the gray wire at the tack to see if you get better spark. You might want to buy a EfI scan tool from a merc dealer to see if you have any codes. Around $400.00 once you do some reading between the manual and the scan tool you may see some good info to start tracing down stuff. Also it might help if you gave us a detailed up to date on all the work you have done so far and what you have not done, and what you have fixed and not fixed as of now. Just curious what state or city do you live in. Also are the batteries new? Also you might want to recheck every ground wire you can find and loosen and re tightin them all just to be shur they are good,Including the ones that go to the rear engine bell housing becouse the grounds for the E C M are hooked up back there to the rear studs.
Boat Tech is offline  
Reply With Quote
Old 04-26-2009, 12:46 PM
  #4
Registered
Thread Starter
 
Join Date: Apr 2009
Posts: 110
Default NOSPARK 7.4 mpi

the boat is a 1976 well craft 25 nova it orgnally had twin 305s in it ive owned the boat 15 years and decided to change it to a single 7.4 with a bravo 3 outdrive , i bought the motor from kentshriver on ebay fresh water motor with low hrs on it , but it was not complete so after putting an addional 2000.00 in it im now at the point of starting the boat and first it didnt turn over if fixed that and now has very little spark when i take off the coil wire and try to jump it to a ground , i replaced the module , primary coil and the coil in the distrubor , cap , rotor , wires and still no change , batteries are new, i put a new wiring merc wiring harness in it and had the boat wired complete by a boat electrion, one strange thing is the volt guage has power but doesnt come up when i turn in the key , all other gauges have movement when i turn the motor over any ideas would help , i live in san diego , thanks james
jimmie is offline  
Reply With Quote
Old 04-26-2009, 01:31 PM
  #5
Charter Member # 55
Charter Member
 
Griff's Avatar
 
Join Date: Oct 2000
Location: Omaha
My Boats: .......32............. ...............Active Thunder....
Posts: 15,748
Default

Quit spending money on parts and go get a merc manual. It has trouble shooting charts that will guide you through everything. Right now, you are just guessing.

Is this an efi engine or carb???? Does it have a TB IV or TB V ignition? I don't know what you replaced inside the distributor, but its not a coil. Maybe the electronic pick up sensor.

Is the ignition module bolted to an exhaust manifold??? The module bracket needs to be grounded also.
Griff is offline  
Reply With Quote
Old 04-26-2009, 06:23 PM
  #6
Registered
Thread Starter
 
Join Date: Apr 2009
Posts: 110
Default 1996 mercruiser 7.4 is a delco ign

im going to try the grounds and see what happens
jimmie is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:55 PM.


Copyright 2011 OffShoreOnly. All rights reserved.