Like Tree0Likes

Memphis Audio speakers? amps? anybody use them?

Reply
Old 05-31-2011, 08:40 PM
  #21
Registered
 
Join Date: Jul 2003
Location: North Las Vegas, NV
My Boats: 92 STV Pro Comp Ski & 86 Scarab 30' Center Console
Posts: 68
Default

I have 4-pair (8) of the Memphis Audio marine 15-MA8's in my boat. The 8" co-axials have good bass response and sound very good. After one season of lite use, and being covered anytime they were not in use (sunbrella cover), I noticed some cracks developing on the cone area. Also, the stock plastic grilles got very brittle and cracked. I ended up cutting the stock grilles so that only the outer surround was left, then covered them with 8" billet sub grilles.

I called Memphis and got the same thing as ChallenSup - buy another set. Not too happy about that, but I went ahead and bought another pair to replace the cracked ones. Supposedly, the updated design now has better UV resilence, but that remains to be seen.

I have noticed that now another pair have cracked cones. I'm not so thrilled with the idea of replacing two pair of speakers every season, but if I decide to stay with these speakers, it may be the case.

Pics:







STV_Keith is offline  
Reply With Quote
Old 02-13-2012, 11:41 AM
  #22
Registered
 
Join Date: Jan 2007
Posts: 263
Default

I just purchase two sets so we can see what they do over this next season. The 6.5 set will be mounted on an arch out in the elements so I hope that I don’t see the same cracking that you did.
1987pachanga22 is offline  
Reply With Quote
Old 02-13-2012, 02:38 PM
  #23
Gold Member
Gold Member
 
Keytime's Avatar
 
Join Date: Jun 2007
Location: Derby, KS
My Boats: 1999 Checkmate 283 Convincor
Posts: 2,730
Default

10', 8's, and 6.5's in my boat. They rip.
Keytime is offline  
Reply With Quote
Old 02-13-2012, 02:46 PM
  #24
Registered
 
Join Date: Mar 2010
Location: Cincinnati Ohio
My Boats: 89 10 meter
Posts: 175
Default

I have (8) 8" and (8) 6.5 " speakers in my boat they have been in there for three season and have not had any issues what so ever. No cracking no blown speakers. I have them powered by JL audio amps and they rock I just need to add a few subs and i should be happy .
redsled33 is offline  
Reply With Quote
Old 02-14-2012, 04:32 PM
  #25
Registered
 
Join Date: Jul 2003
Location: North Las Vegas, NV
My Boats: 92 STV Pro Comp Ski & 86 Scarab 30' Center Console
Posts: 68
Default

I'm sure its the sun, as I've replaced all three sets of speakers that get sun, but not the one set that is under the console out of the sun.
STV_Keith is offline  
Reply With Quote
Old 02-14-2012, 05:56 PM
  #26
Registered
Trade Score: (2)
 
Join Date: Mar 2002
Location: Miami Beach
My Boats: 2009 37 Spectre Diesel CC
Posts: 2,063
Default

never had to replace any JL audio speakers
pstorti is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:52 PM.


Copyright 2011 OffShoreOnly. All rights reserved.