Like Tree0Likes

Need motor advice please

Reply
Old 05-17-2010, 11:35 PM
  #1
Registered
Thread Starter
 
Join Date: Sep 2008
Location: Warwick N.Y.
Posts: 241
Default Need motor advice please

Well first off im not here to bash my engine builder (yet) .I would just like to know what you would do if this happened to you.It all started mid season last year when i pickup my new 540 from my builder.With a some help of a few friend we had the motor in and on the water in no time.Being that this motor was dyno tuned i figured it was drop it in and go(no bugs to work out)First time out we had problems didnt want to idle,had to feather the throttle to get it on plan etc and the motor would just not rev regardless of witch prop we tested.While on the water we found the fuel line was 3/8 but we had some 1/2 so we swap it out real quick.Still not much of a difference.I decided to read the plugs to find the plugs looked like it was running lean.Back on the trailer and a call to the builder to find he mistakely put the wrong plugs in the motor.After a plug change a little better but now it keeps popping the main fuse back to the trailer again.This time we find the builder hooked up a key hot wire that was for a electric fuel pump that was no longer being used to the hot side of my alternator.So now i need a new merc hardness and alternator.(thank god it didnt go on fire)At this point the few friends and myself decide its time to pull the motor and bring it back to the builder.Its now late aug early sept i drop the motor off to the builder and tell him to find the problem and while you have it i want you to install a F.A.S.T. injection system on it and to tune it.I told him to overnight everything and anything he need as i want to use the boat at least a little bit before the season was over.He told me no problem it will take two to three weeks till i have it back.So i get the call that i can pick up my motor its now april.(what the f*$k happened to 3 weeks)To make it more fun the injection system was giving to me in boxs even tho its was ran and tuned on the dyno.$6300 and i have to put it together.Again with alot of help from a few friend the motors in and ready to fun.I put the garden hose on in and (drum roll)i turn the key and NOTHING.Time to start looking for problems and the only thing we can find is that the builder left his oil pressure gauge fitting in the motor (unpluged ) so now i have a $100 in oil in my beilge that i might add my friend just power washed for me.After several calls to the build the only thing i get from him is WELL IT RAN WHEN IT WAS ON THE DYNO.Keep in mind i dropped about $25.000 with him for this motor and that what im told.After talking to FAST they say the dis is bad and to send it back for them to repair.I should have my distributer back in the next day or two so hopfully it will run and maybe i can enjoy my boat.After a very long read(sorry)i would just like to know what you would do. Thanx pete
sonic is offline  
Reply With Quote
Old 05-18-2010, 01:41 AM
  #2
Registered
 
Join Date: Jan 2004
Location: Tennessee
Posts: 4,452
Default

Wow......what would I do????? RUN!!!

Why in God's name would he dyno the engine and then take everything back off of it. I can tell you why....because it was never put on in the first place. No one in their right mind would disassemble an engine after dyno-ing it. I just can not be made to believe that.
I really feel for you since you have spent a ton of money and I know that you would love to make him fix it, but you need to cut your loses and find another builder to fix it. Unfortunately you picked a turd for an engine builder. I would not waste anymore time and money on this guy. Take your stuff to a reputable builder. There are still a few of us that do what we say. Good luck with it.
Eddie
Young Performance is offline  
Reply With Quote
Old 05-18-2010, 02:13 AM
  #3
Charter Member # 55
Charter Member
 
Griff's Avatar
 
Join Date: Oct 2000
Location: Omaha
My Boats: .......32............. ...............Active Thunder....
Posts: 15,738
Default

I would post the name of the engine builder so that everyone knows not to ever go there!!!!!

Like Eddie said, your engine builder is full of chit and lying. Where are the dyno sheets??????
Griff is offline  
Reply With Quote
Old 05-18-2010, 08:47 AM
  #4
Registered
 
Join Date: Dec 2007
Posts: 688
Default

wow thats sucks !! do tell all who is this guy who claims he no how to rip people off!!! thats a lot of$$$$$ for what you got. i paid $700 to have my motor dyno and he did some mods to it to make it run better. it is sad that there are guys out there that ripp you off and dont no what they are doing . i got lucky i find a guy 40 min from my house built my motor in 3 weeks and i went to the shop and watch him dyno my motor . like eddie said my motor had all the parts on it why wuold you take it off????next time you go to the shop talk to other guys that they did work for. they is storys just like your posted here ,after reading them i will not go there !!! good luck on fixing your motor
bajabob is offline  
Reply With Quote
Old 05-18-2010, 09:07 AM
  #5
Banned
 
Join Date: Sep 2007
Location: Frankfort,ill
My Boats: 40 SKATER
Posts: 12,863
Default

post the name of that engine builder so that everyone on OSO knows not to ever go there !!!!! Sounds like 1 we got f cked by in Zona .good luck on getting back 2gether
RunninHotRacing163.1 is offline  
Reply With Quote
Old 05-18-2010, 12:25 PM
  #6
Registered
Trade Score: (1)
 
Join Date: Apr 2002
Location: Lake of the ozarks
My Boats: 40 Skater 607Ci 14:71 TF Kobelco
Posts: 1,234
Default

Quote:
Originally Posted by Young Performance View Post
Wow......what would I do????? RUN!!!

Why in God's name would he dyno the engine and then take everything back off of it. I can tell you why....because it was never put on in the first place. No one in their right mind would disassemble an engine after dyno-ing it. I just can not be made to believe that.
I really feel for you since you have spent a ton of money and I know that you would love to make him fix it, but you need to cut your loses and find another builder to fix it. Unfortunately you picked a turd for an engine builder. I would not waste anymore time and money on this guy. Take your stuff to a reputable builder. There are still a few of us that do what we say. Good luck with it.
Eddie
Eddie
Agree 100%
WOW
Jim
www.ozarkspeedandmarine.com
thumper038 is offline  
Reply With Quote
Old 05-18-2010, 03:55 PM
  #7
Platinum Member
Platinum Member
 
boatfreak's Avatar
 
Join Date: Mar 2002
Location: Indy
My Boats: 2004 37 ActiveThunder
Posts: 2,496
Default

WOW I'm sorry to hear another story like this. If what you have told us is 100% true then I wouldn't hesitate to name this jerk. I sure wouldn't worry about him fixing it as I wouldn't want him near it. Like Eddie said cut your loses and find someone who can get things lined out for you. I had Eddie build two 720's for me last year and when I left his shop I was completely comfortable with my set up. He not only runs them on the dyno but installs everything so if there is a problem it is taken care of before you leave.
boatfreak is offline  
Reply With Quote
Old 05-18-2010, 04:06 PM
  #8
Rob
VIP Member
Trade Score: (6)
 
Strip Poker 388's Avatar
 
Join Date: Aug 2001
Location: Madison,Mississippi
My Boats: Hustler 388
Posts: 21,567
Default

thats suxs,maybe someone here can recommend ya someone close to ya that will get ya going.Goodluck\

Rob
Strip Poker 388 is offline  
Reply With Quote
Old 05-19-2010, 08:32 PM
  #9
Registered
Thread Starter
 
Join Date: Sep 2008
Location: Warwick N.Y.
Posts: 241
Default

Thanx for all the replys.I will let everyone know how the builder is as soon as i can fix this mess.Eddie do you know anything about the fast system or know of someone that does.My builder is a jacka$$ and the guys at fast dont seem to care about helping you.Thanx pete
sonic is offline  
Reply With Quote
Old 05-19-2010, 09:28 PM
  #10
Registered
Thread Starter
 
Join Date: Sep 2008
Location: Warwick N.Y.
Posts: 241
Default

Quote:
Originally Posted by DareDevil View Post
Please don't tell us his first name starts with a D ???????
No It starts with a J
sonic is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:53 AM.


Copyright 2011 OffShoreOnly. All rights reserved.