Like Tree0Likes

Changed the impeller today, glad I did! (Pic)

Reply
Old 05-24-2010, 11:55 PM
  #1
Registered
Thread Starter
 
Join Date: Jan 2010
Location: Iowa
My Boats: '91 Baja Islander 208
Posts: 53
Default Changed the impeller today, glad I did! (Pic)

Bought my boat last summer and finally got the balls to change the impeller. I dropped the lower unit but the water tube sleeve stayed in the upper, so I reached up and pulled this mess out.


The previous owner really roasted this thing! Guess someone ran it dry for quite a while. Luckily no other damage was found and the rest of the job went smoothly.
hopper75 is offline  
Reply With Quote
Old 05-25-2010, 11:03 AM
  #2
Gold Member
Gold Member
 
Big Time's Avatar
 
Join Date: Aug 2007
Location: Westport, CT
Posts: 1,470
Default

Yeah, they are not supposed to look like that! Mine gets switched out every year.
Big Time is offline  
Reply With Quote
Old 05-25-2010, 02:01 PM
  #3
Member #154
Platinum Member
 
Indy's Avatar
 
Join Date: Oct 2000
Location: SW CT & Long Island Sound
My Boats: Missing my PowerPlay
Posts: 6,756
Default

Quote:
Originally Posted by Big Time View Post
Yeah, they are not supposed to look like that! Mine gets switched out every year.
I changed mine once a year too, or after I think I've sucked up some sand.
Indy is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:57 PM.


Copyright 2011 OffShoreOnly. All rights reserved.