Like Tree0Likes

Broken bell housing

Reply
Old 06-01-2010, 10:09 PM
  #1
Registered
Thread Starter
 
Join Date: Mar 2010
Location: QLD
My Boats: 21' Revolution 09' (Name Revolution Racing)
Posts: 229
Default Broken bell housing

Has anyone ever broken the rear engine mounts that are incorporated into the bell housing on their stern drive setups?

Are the bell housings beefed up in the larger HP mercruiser range or are they similar all the way through?

Pretty sure this is what happened to a mate the other week, it made a mess of the transom assembly and rubber drive coupler. The bell housing is in a million bits cause the shaft flogged around inside it but im pretty confident it was the bell housing that failed first and from there it was like a grenade went off.
Kurt Hamilton is offline  
Reply With Quote
Old 06-01-2010, 10:17 PM
  #2
Platinum Member
Platinum Member
Trade Score: (3)
 
mike tkach's Avatar
 
Join Date: Oct 2007
Location: yorkville,il
My Boats: 31 american offshore,38 fountain fever
Posts: 8,111
Default

my bet is that the coupler broke first,and the boll housing just happend to be in the way of the flying parts.
mike tkach is offline  
Reply With Quote
Old 06-01-2010, 10:37 PM
  #3
Registered
Thread Starter
 
Join Date: Mar 2010
Location: QLD
My Boats: 21' Revolution 09' (Name Revolution Racing)
Posts: 229
Default

The bell housing just looks like very thin pourous cast aluminium?
How often do the drive couplers fail?
Its one of those things i guess, you could blame it on either but once everything is in a million pieces how can you tell what went first.
Kurt Hamilton is offline  
Reply With Quote
Old 06-02-2010, 12:40 AM
  #4
Charter Member # 55
Charter Member
 
Griff's Avatar
 
Join Date: Oct 2000
Location: Omaha
My Boats: .......32............. ...............Active Thunder....
Posts: 15,748
Default

Couplers fail about a 1000x more often than a bell housing, especially if they are out of alignment or not greased. I've never even heard of bell housing being a cause of a failure. I would also say a coupler failure caused the broken bell housing.

I will tell you I had a u-joint let go at 6000rpm in drag car and it broke the tranny bell housing and yoke on the rear end in the car.
Griff is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:19 PM.


Copyright 2011 OffShoreOnly. All rights reserved.