Like Tree0Likes

Donzi 22zx 454 mpi procharged questions

Reply
Old 06-07-2010, 12:47 AM
  #1
Registered
Thread Starter
 
snake plissken's Avatar
 
Join Date: Jun 2005
Location: Santa Fe N.M
My Boats: Donzi 1999 22ZX procharged Dana Headers Jacobs Ignition
Posts: 59
Default Donzi 22zx 454 mpi procharged questions

Ok here it goes I have a 454 Mpi M1sc procharged runs great professionaly installed at AZ speed and Marine only problem is it wont idle all that good picked up lots of speed but it wont idle worth a damn . Yea I know every time I post i get responces that the 454 Mpi has cast pistons and all that but thats not the problem ever since I had it installed its never idled right and I have about 40 hours on it since then and drives me crazy and Ideas thoughts? ok the second question I put a new drive with a one ince spacer seems to have picked up some speed but the front of the boat on top end really bounces so i need to use the trim tabs set at 4 to stop it from bouncing .just thinking about taking it off also need to have the tabs set at 4 to get it to plane as well and thoughts would be great thanks
snake plissken is offline  
Reply With Quote
Old 06-07-2010, 01:10 AM
  #2
Registered
 
ZXXX Donzi's Avatar
 
Join Date: Jun 2004
Location: Tennessee
My Boats: Fountain 35 w/500 EFI's, 1973 Donzi X-18 w/383 Mag,1974 Chris Craft Roamer w/1271TI's
Posts: 834
Default

Quote:
Originally Posted by snake plissken View Post
Ok here it goes I have a 454 Mpi M1sc procharged runs great professionaly installed at AZ speed and Marine only problem is it wont idle all that good picked up lots of speed but it wont idle worth a damn . Yea I know every time I post i get responces that the 454 Mpi has cast pistons and all that but thats not the problem ever since I had it installed its never idled right and I have about 40 hours on it since then and drives me crazy and Ideas thoughts? ok the second question I put a new drive with a one ince spacer seems to have picked up some speed but the front of the boat on top end really bounces so i need to use the trim tabs set at 4 to stop it from bouncing .just thinking about taking it off also need to have the tabs set at 4 to get it to plane as well and thoughts would be great thanks
Sounds like they got the tune wrong. I have never dealt with them but have heard a number of issues with that.

Have you looked at the plugs and is the transom getting lots of soot?
ZXXX Donzi is offline  
Reply With Quote
Old 06-07-2010, 01:30 AM
  #3
Registered
 
Join Date: Jan 2005
Posts: 185
Default

Did it ever idle ok? Does it idle ok in neutral and not in gear or ? Does it "load" up? Have you tried a bit more idle blade? Is the IAC motor working? Who's the girl in your avatar?
RichardCranium572 is offline  
Reply With Quote
Old 06-07-2010, 01:37 AM
  #4
Registered
Thread Starter
 
snake plissken's Avatar
 
Join Date: Jun 2005
Location: Santa Fe N.M
My Boats: Donzi 1999 22ZX procharged Dana Headers Jacobs Ignition
Posts: 59
Default

It used to idle before. and it dont matter if its in neutral or in gear.I have been boating for years but fill me in what is idle blade? and I have heard of the term loading up but clearify it for me please Thanks Vince
snake plissken is offline  
Reply With Quote
Old 06-07-2010, 01:38 AM
  #5
Registered
Thread Starter
 
snake plissken's Avatar
 
Join Date: Jun 2005
Location: Santa Fe N.M
My Boats: Donzi 1999 22ZX procharged Dana Headers Jacobs Ignition
Posts: 59
Default

oh and The girl in my avatar is my girl
snake plissken is offline  
Reply With Quote
Old 06-07-2010, 03:44 AM
  #6
Registered
 
Join Date: Jan 2005
Posts: 185
Default

Sorry, I meant to say throttle blade, not idle blade. If it idled before and all of a sudden has quit idling I would assume your IAC motor has failed. It's a small black round device(around 1" in diameter) on the throttle body that has 4 wires connected to it.(blu/wht, blu/blk, grn/wht, grn/blk). When this device fails, the computer cannot aid in controlling idle speed. Less likely is that the IAC drivers in the computer have failed.

What you can do in the meantime is crack open the throttle blade adjustment so it idles correctly in neutral, this is a good base setting until you can replace the IAC motor. This adjustment requires an 1/8" allen wrench. There are two adjustment set screws in the throttle body, I would recommend you open the secondary throttle blade instead of the primary throttle blade so as not to affect the TPS voltage.

"Loading up" is a term we use to say that the engine is way too rich at idle, easiest way to tell is after idling for a while the engine starts misfiring and when you rev the throttle you get excessive black smoke and burbling sound out of the exhaust until the spark plugs clean themselves off a bit.

Last edited by RichardCranium572; 06-07-2010 at 03:48 AM.
RichardCranium572 is offline  
Reply With Quote
Old 06-08-2010, 05:58 PM
  #7
Registered
Thread Starter
 
snake plissken's Avatar
 
Join Date: Jun 2005
Location: Santa Fe N.M
My Boats: Donzi 1999 22ZX procharged Dana Headers Jacobs Ignition
Posts: 59
Default

Thank You Richard for your advise I will keep you posted im going to start with the iac motor as you suggested and then go from there
snake plissken is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:41 PM.


Copyright 2011 OffShoreOnly. All rights reserved.