Like Tree0Likes

Mercury Sportjet 120 Problems - Anyone Familiar With These?

Reply
Old 07-29-2010, 09:07 PM
  #1
Registered
Thread Starter
 
TEAMBAJA's Avatar
 
Join Date: Dec 2002
Location: Bucyrus, Ohio
My Boats: 24 OUTLAW
Posts: 6,654
Default Mercury Sportjet 120 Problems - Anyone Familiar With These?

A friend of mine has a little Checkmate Jetboat with the Mercury Sportjet 120. The boat starts and runs fine, but wont get on plane, the engine just starts to rev. Anyone had this problem or have any suggestions. Several people have looked at it with no luck.
TEAMBAJA is offline  
Reply With Quote
Old 07-29-2010, 09:17 PM
  #2
Registered
 
monstaaa's Avatar
 
Join Date: Feb 2005
Location: long island, newyork
My Boats: 3kids
Posts: 2,551
Default

is it jet drive? if it is you may need an impellar or some thing may b stuck in the pump housihjng.
monstaaa is offline  
Reply With Quote
Old 08-01-2010, 10:18 PM
  #3
Registered
Thread Starter
 
TEAMBAJA's Avatar
 
Join Date: Dec 2002
Location: Bucyrus, Ohio
My Boats: 24 OUTLAW
Posts: 6,654
Default

Quote:
Originally Posted by monstaaa View Post
is it jet drive? if it is you may need an impellar or some thing may b stuck in the pump housihjng.
Yes. Everything is clear and the impellar is good.

No one has any experience with these?
TEAMBAJA is offline  
Reply With Quote
Old 08-02-2010, 08:16 AM
  #4
Registered
 
Join Date: Mar 2006
Location: Atlantic City, NJ
Posts: 597
Default

does it try and move at all or does it just rev? You might double check to make sure there are no obstructuions
SVL-WARLOCK is offline  
Reply With Quote
Old 08-02-2010, 08:34 AM
  #5
Platinum Member
Platinum Member
 
RVRCAT28's Avatar
 
Join Date: Jul 2001
Location: St. Louis, MO/ Pinellas Park, FL
My Boats: Skater
Posts: 163
Default

Make sure the seal is intact around the intake grate.
RVRCAT28 is online now  
Reply With Quote
Old 08-02-2010, 09:39 AM
  #6
VIP Member
VIP Member
 
salesmanship's Avatar
 
Join Date: Mar 2001
Location: Cape Coral FL
My Boats: boats
Posts: 2,159
Default

Quote:
Originally Posted by RVRCAT28 View Post
Make sure the seal is intact around the intake grate.

I had one of those a few years ago. That's exactly what was wrong. Replace the seal.
salesmanship is offline  
Reply With Quote
Old 08-02-2010, 02:21 PM
  #7
SORE MEMBER
Platinum Member
 
Wobble's Avatar
 
Join Date: Apr 2004
Location: 2950'49.74"N 95 5'17.55"W.......TEXAS
My Boats: SeaDoo RXP & RXP-X, Stryker Equalizer 28, Eliminator Daytona Jet
Posts: 6,709
Default

for jet skis in general, if the seal around the shaft is bad it allows air in front of the impeller which causes cavitation. May or may not be leaking inside.
Wobble is offline  
Reply With Quote
Old 08-03-2010, 10:00 AM
  #8
Registered
Thread Starter
 
TEAMBAJA's Avatar
 
Join Date: Dec 2002
Location: Bucyrus, Ohio
My Boats: 24 OUTLAW
Posts: 6,654
Default

Thanks for the replys, I'll check out the seals! I'll post an update when its fixed.

SVL-WARLOCK, yes the boat moves. You could idle to Canada.
TEAMBAJA is offline  
Reply With Quote
Old 08-07-2010, 12:22 PM
  #9
Registered
 
Join Date: Oct 2007
Location: Toms River, NJ
My Boats: WWW.SHOREMOTORSPORTS.COM 732-349-2999
Posts: 205
Default

check all seals, air is getting in there somewhere
panicrev is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:18 AM.


Copyright 2011 OffShoreOnly. All rights reserved.