Like Tree0Likes

Question Holley 800 double pumper misfire

Reply
Old 09-10-2010, 12:08 PM
  #1
Registered
Thread Starter
 
Join Date: Aug 2008
Posts: 48
Default Question Holley 800 double pumper misfire

I have a Holley 800 double pumper marine carb with electric choke. It is misfiring at pedal down full load. It is on 454 marine engine. This new carb work great for the first 8 hours of use, but now it is started to back firer or hesitate on fast throttle take off, but if you bring the throttle up slow it does not back fire or hesitate . It works just fine on wide open cruising throttle or idle. It is just on fast throttle take off that I am having the problem. Also fuel is at 6 PSI when running, it squirting fuel form the nozzles when throttling and choke is working proper. Any help?

Last edited by mslitti; 09-10-2010 at 12:36 PM.
mslitti is offline  
Reply With Quote
Old 09-10-2010, 02:19 PM
  #2
SORE MEMBER
Platinum Member
 
Wobble's Avatar
 
Join Date: Apr 2004
Location: 2950'49.74"N 95 5'17.55"W.......TEXAS
My Boats: SeaDoo RXP & RXP-X, Stryker Equalizer 28, Eliminator Daytona Jet
Posts: 6,705
Default

check and make sure that all the rubber plugs are still on the vacuum/signal ports. Good idea to tie-wrap them on
Wobble is offline  
Reply With Quote
Old 09-11-2010, 08:22 AM
  #3
Lakeside Restorations.com
Commercial Member
 
LAKESIDE RESTORATIONS's Avatar
 
Join Date: Nov 2003
Location: NorthEastern, PA
Posts: 2,512
Default

You could have an issue with your ignition or its advance..
__________________
www.LakesideRestorations.com 570-639-2628
We Make Fast Toys Faster, Cool Toys Cooler and Old Toys New!.. Performance, Custom & OEM Parts & much MORE![/CENTER]
LAKESIDE RESTORATIONS is offline  
Reply With Quote
Old 09-11-2010, 09:23 AM
  #4
Registered
 
Join Date: Apr 2005
Location: Annapolis,md
My Boats: 33' Powerplay
Posts: 132
Default

Sounds like your power valve is blown, threads into the metering block. It will blow when there is a backfire.
macjazzy is offline  
Reply With Quote
Old 09-11-2010, 09:42 AM
  #5
instigator
Platinum Member
 
BUIZILLA's Avatar
 
Join Date: May 2003
Location: Miami, Fla
My Boats: 1980 Donzi Criterion 22
Posts: 1,420
Default

sounds lean on the primary side,
BUIZILLA is offline  
Reply With Quote
Old 09-11-2010, 10:34 AM
  #6
Registered
 
Join Date: Jul 2007
Location: San Diego
My Boats: Advantage 28ft Sport Cat w/ pair of 8's
Posts: 989
Default

I had the same issue on my ski boat. It ended up being a simple air passage being blocked. I used high pressure air to blow them out and sure enough, one was blocked. It took about a month to figure that one out.

Darrell.
DMOORE is offline  
Reply With Quote
Old 09-12-2010, 06:46 AM
  #7
Platinum Member
Platinum Member
 
Join Date: May 2003
Posts: 160
Default

Sounds like a lean condition in the idle circuit. Back off the idle screws half a turn. I don't know where you live, but as the air cools, the circuits have to be richened. The best way to check the complete RPM range is with an air/fuel ratio meter.
Boxer is offline  
Reply With Quote
Old 09-12-2010, 08:44 AM
  #8
VIP Member
VIP Member
 
JIMKID Motorsports's Avatar
 
Join Date: Mar 2001
Location: Livonia Mi Usa
My Boats: 2009 30 LS7 SKATER 711 sold xvi power
Posts: 1,912
Default

hay guys if it works okay on easy accells then the carb should be okay the enrichment curcuit is the accellerator pump right when he hits it hard and a buch of air goes in it needs fuel thats when the pump should help sounds like a lack of pump shot to me my three cents worth inflatoin you know
__________________
30 SKATER LS7
JIMKID Motorsports is offline  
Reply With Quote
Old 09-13-2010, 10:31 AM
  #9
SORE MEMBER
Platinum Member
 
Wobble's Avatar
 
Join Date: Apr 2004
Location: 2950'49.74"N 95 5'17.55"W.......TEXAS
My Boats: SeaDoo RXP & RXP-X, Stryker Equalizer 28, Eliminator Daytona Jet
Posts: 6,705
Default

Quote:
Originally Posted by JIMKID Motorsports View Post
hay guys if it works okay on easy accells then the carb should be okay the enrichment curcuit is the accellerator pump right when he hits it hard and a buch of air goes in it needs fuel thats when the pump should help sounds like a lack of pump shot to me my three cents worth inflatoin you know
I was thinking the same, he said it was squirting and will run wot.

Trash in the carb or a weak ignition component, maybe a mechanical advance issue.

Back to basics.
Wobble is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:10 AM.


Copyright 2011 OffShoreOnly. All rights reserved.