Like Tree0Likes

She lives...!!!!

Reply
Old 02-09-2011, 10:58 AM
  #1
Registered
Thread Starter
Trade Score: (-1)
 
Join Date: Mar 2010
Location: Cowichan Station BC
My Boats: Small fishing boat right now :-(
Posts: 495
Default She lives...!!!!

Well, after a long few months I finally got the new motor in and running, sounds pretty good, just need a nice day of weather to water test her and make any needed adjustments.

Boat is a 1997 23' Scarab SCS, motor is a fresh total rebuilt 1996 Gen VI 454 Mag MPI (with a few internal 'tweaks") and a M-1SC Procharger @ 5lbs boost. Had very good dyno numbers and looking forward to hitting the water.

I just wanted to thank numerous people from OSO who answered my silly questions throughout the build, some of you who I even spoke to on the phone..... I did not realize how much was involved with installing a Procharger, especially when you are doing it by yourself in a small garage out in the middle of the "sticks".....

A couple of plugs to some really helpful guys:

Mark Boos http://www.pmefi.com/

Alex Haxby http://www.haxbyspeed.com/

Eddie Young http://www.youngperformancemarine.com/


All these guys, as well as others provided vast knowledge which helped me get the job done, thank you. Jeremy

PS. A small clip of my son and I getting her running in the boat for the first time.....

http://www.youtube.com/watch?v=TzmJe4l3GDc
FogduckerIII is offline  
Reply With Quote
Old 02-09-2011, 04:42 PM
  #2
Platinum Member
Platinum Member
Trade Score: (1)
 
dykstra's Avatar
 
Join Date: Dec 2003
Location: Washington, IL
My Boats: 29' FOUNTAIN 525SC
Posts: 5,341
Default

Looks and sounds good.
dykstra is offline  
Reply With Quote
Old 02-09-2011, 07:11 PM
  #3
Registered
Thread Starter
Trade Score: (-1)
 
Join Date: Mar 2010
Location: Cowichan Station BC
My Boats: Small fishing boat right now :-(
Posts: 495
Default

Quote:
Originally Posted by dykstra View Post
Looks and sounds good.
Thank you, now to get a good day and see if she runs as well.....
FogduckerIII is offline  
Reply With Quote
Old 02-14-2011, 10:30 PM
  #4
Registered
 
ZXXX Donzi's Avatar
 
Join Date: Jun 2004
Location: Tennessee
My Boats: Fountain 35 w/500 EFI's, 1973 Donzi X-18 w/383 Mag,1974 Chris Craft Roamer w/1271TI's
Posts: 834
Default

That is awesome Jeremy. There is nothing like that feeling when the blower kicks in for the first time.
ZXXX Donzi is offline  
Reply With Quote
Old 02-14-2011, 10:47 PM
  #5
Registered
 
Join Date: Jan 2011
Location: SoCal
My Boats: Eliminator
Posts: 2,228
Default

PokerRun388 is offline  
Reply With Quote
Old 02-15-2011, 10:58 AM
  #6
Registered
Thread Starter
Trade Score: (-1)
 
Join Date: Mar 2010
Location: Cowichan Station BC
My Boats: Small fishing boat right now :-(
Posts: 495
Default

Quote:
Originally Posted by ZXXX Donzi View Post
That is awesome Jeremy. There is nothing like that feeling when the blower kicks in for the first time.
I am looking forward to it but this damn rain won't stop..............
FogduckerIII is offline  
Reply With Quote
Old 02-15-2011, 10:59 AM
  #7
Registered
Thread Starter
Trade Score: (-1)
 
Join Date: Mar 2010
Location: Cowichan Station BC
My Boats: Small fishing boat right now :-(
Posts: 495
Default

Quote:
Originally Posted by PokerRun388 View Post
???????
FogduckerIII is offline  
Reply With Quote
Old 02-15-2011, 11:40 AM
  #8
Registered
 
Join Date: Dec 2004
Location: Ft Lauderdale. Fl
My Boats: 2004 Jaws Center Console. 1993 SuperBoat 24 gone.
Posts: 277
Default

The orange motor looks great! what did you paint it with? I think pokerrun meant drop jaw good?
budd is offline  
Reply With Quote
Old 02-15-2011, 12:51 PM
  #9
Registered
Thread Starter
Trade Score: (-1)
 
Join Date: Mar 2010
Location: Cowichan Station BC
My Boats: Small fishing boat right now :-(
Posts: 495
Default

Quote:
Originally Posted by budd View Post
The orange motor looks great! what did you paint it with? I think pokerrun meant drop jaw good?
I had a couple of cans of high heat engine paint kicking around from another project, at first I was going to just use it to splash the motor and paint it up a different colour after the rebuild but the colour kind of grew on me, plus the other half pointed out it matching the piping on the seats...

I think it looks good with the black and stainless, the Fram filter will be gone very shortly, had the Wix on back-order.........
FogduckerIII is offline  
Reply With Quote
Old 11-22-2011, 11:44 AM
  #10
Registered
 
Join Date: May 2011
Location: Cypress, TX
My Boats: 1997 Scarab SCS
Posts: 197
Default

Well how did the boat run? what king of MPH and what prop are you running? Looks like a great project!
BBADWS6 is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:56 AM.


Copyright 2011 OffShoreOnly. All rights reserved.