Like Tree0Likes

Has anyone saved a catastrophic engine failure

Reply
Old 02-16-2011, 12:34 PM
  #11
Gold Member
Gold Member
Trade Score: (2)
 
kreed's Avatar
 
Join Date: Feb 2008
Location: Connecticut
Posts: 6,349
Default

I was refering to my Bullet. Ive only had the Hawk out once when I bought it so far....but I loved loved loved the way it sounded! Really lookin forward to this boat. Are you guys the ones in the video on youtube with the Velocity jumping out of the water?
kreed is offline  
Reply With Quote
Old 02-16-2011, 12:40 PM
  #12
Crazy Energy
Platinum Member
Thread Starter
Trade Score: (4)
 
Velocity Vector's Avatar
 
Join Date: Aug 2007
Location: Oklahoma God's country no one else wants it.
My Boats: Old Skool 35' Ocean Express Cat 1700 HP
Posts: 4,340
Default

Yes that's me post 10 I put up the video
Velocity Vector is offline  
Reply With Quote
Old 02-16-2011, 12:44 PM
  #13
S.O.B (single O/B) now
Platinum Member
 
t500hps's Avatar
 
Join Date: Sep 2004
Location: Richmond VA
Posts: 7,919
Default

yep.....running 4,200 rpms on a poker run and the oil pressure dropped to 0!!!! Engine alarms went off and I shut it down before even coming off plane.

Pulled the motor and dropped the pan to find the pickup tube broke off. Re-installed/welded the tube and put it back together....4 years later still running strong.
t500hps is offline  
Reply With Quote
Old 02-16-2011, 12:45 PM
  #14
Beak botr
VIP Member
 
88Fount33's Avatar
 
Join Date: Dec 2003
Location: Cape Coral
My Boats: 1988 Fountain 8.8
Posts: 890
Default I saved a 406 CI small block once.

Built a 406 CI small block in 2000, blew it up in 1 month, as I was running way too much timing trying to make a slow hull fast.

The rotating assembly kit, had the block line bored and honed thus requiring a very specific rear main seal that was oversize (this oversized seal was in the original kit, it had a wire tied note stating "this is a special RMS for blocks that have been line bored and align honed).

Needless to say, when I ordered the replacement seal from parts store for the rebild of the blown engine, told them two or three times it was a 'special align honed size RMS' only to have them give me std seal, which was many thousands of an inch too small but you would not notice it by eyeball test.

Assembled engine and ran for several hours in driveway, and then just floating next to dock. Took off with the family up the lake and after about 20 minutes just happened to look down and catch the oil pressure gauge (mechanical) dropping to zero. reached over and turned the key to off and it hit off almost exactly the same time the idiot light lit.

Eight quarts of oil in the bilge, thank goodness I had disconnected the auto float on the bilge pump. It happened about 300 yards away from a marina, got a tow over and purchase a case of oil. filled it and started the trip back to the house, when I saw the needle of the gauge first wiggle, switched off and refilled engine. Took only one refill to get home.

The next week removed and disassembled, could find no damage to the bearings and clearances were perfect. New
Seal and new rings reused bearings and that engine is still running somewhere in upstate.
88Fount33 is offline  
Reply With Quote
Old 02-16-2011, 01:34 PM
  #15
Registered
Trade Score: (4)
 
Rookie's Avatar
 
Join Date: Jan 2003
Location: Grand Rapids, MI
My Boats: 30 Scarab Panther, 37 Active Thunder, 34 Wellcraft Gran Sport
Posts: 3,788
Default

I have my electric fuel pumps and ignition tied into the oil pressure switch. Port engine died all of a sudden at 5100RPM. Opened the hatch and had oil everywhere. Oil filter had loosened and pumped all of my oil into the bilge. Went home filled engine back up, started and let idle for a while. Shut down, removed filter, cut it open and inspected for shavings. Looked good and ran for another 3yrs without any problems.
Rookie is offline  
Reply With Quote
Old 02-16-2011, 01:37 PM
  #16
Banned
 
Join Date: Sep 2007
Location: Frankfort,ill
My Boats: 40 SKATER
Posts: 12,863
Default

Quote:
Originally Posted by Velocity Vector View Post
And wild it was brother! I still have nightmares.
Stupid caught on tape.
http://www.youtube.com/watch?v=Mqe4Y...lnk&feature=BF
Kreed your boat and endevor BT is in this video too.


motors sound sweet whats with the HOMO muzik
RunninHotRacing163.1 is offline  
Reply With Quote
Old 02-16-2011, 01:43 PM
  #17
Registered
 
Join Date: Jul 2009
Location: Grosse Pointe Farms, MI
My Boats: 85 Baja Force 320
Posts: 1,570
Default

Quote:
Originally Posted by t500hps View Post
yep.....running 4,200 rpms on a poker run and the oil pressure dropped to 0!!!! Engine alarms went off and I shut it down before even coming off plane.

Pulled the motor and dropped the pan to find the pickup tube broke off. Re-installed/welded the tube and put it back together....4 years later still running strong.
That's awesome!

It's tough to say if I've ever "saved" a motor, but I am pretty good about not using something and investigating the "real" problem behind a tick or squeal or whatnot before beating the crap out of it and breaking it worse. I have a couple of friends that just run it until it breaks and then they find the real problem, and often 2-3 more problems...
wjb21ndtown is offline  
Reply With Quote
Old 02-16-2011, 03:02 PM
  #18
Crazy Energy
Platinum Member
Thread Starter
Trade Score: (4)
 
Velocity Vector's Avatar
 
Join Date: Aug 2007
Location: Oklahoma God's country no one else wants it.
My Boats: Old Skool 35' Ocean Express Cat 1700 HP
Posts: 4,340
Default

Quote:
Originally Posted by RunninHotRacing163.1 View Post
motors sound sweet whats with the HOMO muzik

I was driving the boat not making the video or music
Velocity Vector is offline  
Reply With Quote
Old 02-16-2011, 03:08 PM
  #19
Banned
 
Join Date: Sep 2007
Location: Frankfort,ill
My Boats: 40 SKATER
Posts: 12,863
Default

Quote:
Originally Posted by Velocity Vector View Post
I was driving the boat not making the video or music
U got mail,U got mail,U got mail .....
RunninHotRacing163.1 is offline  
Reply With Quote
Old 02-16-2011, 03:10 PM
  #20
Crazy Energy
Platinum Member
Thread Starter
Trade Score: (4)
 
Velocity Vector's Avatar
 
Join Date: Aug 2007
Location: Oklahoma God's country no one else wants it.
My Boats: Old Skool 35' Ocean Express Cat 1700 HP
Posts: 4,340
Default

Quote:
Originally Posted by RunninHotRacing163.1 View Post
U got mail,U got mail,U got mail .....

Why thank you your video is way better than mine
Velocity Vector is offline  
Reply With Quote
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:15 PM.


Copyright 2011 OffShoreOnly. All rights reserved.