Go Back  Offshoreonly.com > General Discussion > General Boating Discussion
Aftermarket exhaust reversion problem >

Aftermarket exhaust reversion problem

Aftermarket exhaust reversion problem

Old 04-13-2011, 05:32 PM
  #1  
Registered
Thread Starter
 
Join Date: Apr 2011
Posts: 10
Default Aftermarket exhaust reversion problem

Hi there,

I was wondering if anyone has experienced water reversion problems with the Dana Marine Flow Torque exhaust with the short aluminum risers. The set Im referring to is made to fit silent choice or "S" pipe applications.

I have a completely factory stock 21 Hallett with the Gen.5 Mercruiser 454 Magnum EFI engine. It has the original Hallett installed S pipe exhaust configuration that exits out the transom through SS angle cut tips with internal flappers.

The exhaust described above was recommended by Dana Marine as a direct replacement for my application.

My first outing with the new exhaust (less than 5hrs run time) and I am experiencing water reversion. I never had this problem with my stock manifolds.

Has anybody had this problem with Dana exhaust and a completely stock engine?

Thank you.
TopChoice is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


OSO Sponsor
OSO Advertiser
OSO Advertiser

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.

OSO Advertiser