Like Tree0Likes

Fired up the modified motor today but..

Reply
Old 05-28-2002, 12:21 AM
  #11
loosecannon22
Guest
 
Posts: n/a
Default

I just modified my 7.4 with a complete crane setup as well. I chose the hydraulic cam that they made for the older 420 hp mercs. all is well with the engine and it turns 5300 without any hicups. I can get the part # for you if need be, but its listed on thier website as the cam for 350 365 400 and 420 hp engines. works great sounds great in 7.4's. I modified a 98 gen 5. i wouldnt see a prob with an older one.
 
Reply With Quote
Old 05-28-2002, 08:38 AM
  #12
Registered
 
GregP's Avatar
 
Join Date: Apr 2001
Location: Annapolis MD
My Boats: 1989 Scorpion 32 CC
Posts: 1,464
Default

Bo - Are you sure the cam is in right? I run a LOT more lift and duration Crane cam (235/245 - .553/.573), have domed pistons (about 0.15" dome), and still have plenty of clearance. I'd check your cam card for where the lobe centerline is supposed to be and put a degree wheel on the crank referenced to TDC and make sure the cam isn't somehow out of time.

-Greg
GregP is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ratman
General Boating Discussion
35
08-23-2006 01:26 AM
ratman
General Boating Discussion
13
08-08-2005 09:55 AM
THRILLSEEKER
General Q & A
11
07-24-2003 08:57 AM
Madcow
General Boating Discussion
21
05-13-2002 08:31 PM
MACDAD260
General Boating Discussion
13
04-17-2002 11:55 PM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:07 AM.


Copyright 2011 OffShoreOnly. All rights reserved.