Like Tree0Likes

496Mag Ho's

Reply
Old 07-15-2002, 11:20 AM
  #1
Registered User
Thread Starter
 
boatinbill's Avatar
 
Join Date: Feb 2002
Location: Belleville, IL
My Boats: '99, Formula, 27' Fastech
Posts: 199
Default 496Mag Ho's

Anyone have expereince with the 496Mag HO? WOuld like to hear the good and the bad about these motors.
boatinbill is offline  
Reply With Quote
Old 07-15-2002, 11:36 AM
  #2
Rough Seas Lie Ahead
Gold Member
 
Reckless32's Avatar
 
Join Date: Feb 2002
Location: Virginia Beach, VA
Posts: 2,465
Default

They had some hiccups when they first hit the street with a rod change and fuel rail wiring harness change (only on early serial numbers). I just turned 295 hours since late June '01 and mine has been rock solid. Put a K&N filter on it and it didn't do squat like it did on my previous 502mag boat. Gotta love the closed loop system as well...

Last edited by Reckless32; 07-16-2002 at 12:23 PM.
Reckless32 is offline  
Reply With Quote
Old 07-15-2002, 11:40 AM
  #3
Platinum Member
Platinum Member
 
CigDaze's Avatar
 
Join Date: Jun 2001
Location: St. Petersburg, FL
My Boats: Cigarette 35 Cafe Racer
Posts: 21,346
Default

I've got one. It's a strong, reliable, turnkey engine. No problems here either after 130 hours. The bugs are ironed out and I'm not aware of any problems with them. The closed cooling very convenient and delivers consistant temperatures in all weather and water conditions.
CigDaze is offline  
Reply With Quote
Old 07-15-2002, 11:43 AM
  #4
Registered
 
Join Date: Dec 2000
Location: Solomons Island, Md
Posts: 916
Default

I have two in my boat. I have nothing bad to say. I can't comment on how they compare to the 502efi that it replaced since I never owned any of those. I have read on this board that poeple have had nagging issues with 502s such as buring oil, leaking oil, etc. Then there's the issue with the wet joint exhaust on the 502's.

The 496hos I have don't have any of those issues. As far as oil consuption in my motors, the spare quart of oil that I keep on board is covered in dust since it has never been touched. My motor do not seem to use a drop.

Also - you've got to love the dry joint exhaust. No more rust weeping down the side or concerns about replacing the gasket between manifold and riser.

Also - closed cooling, and the air pump that blows the sea water out of the system without having to pull those silly blue plugs.

The only thing I can complain about is the placement of the seawater pump. This winter I will be replacing the impellers since two seasons is the most I will run on them. I have no idea how I'm going to get at the pumps. They are in a bad spot.

As far as speed - I see 77+ on gps in my boat with 27 labbed 3 blades.
29 OUTLAW is offline  
Reply With Quote
Old 07-15-2002, 12:53 PM
  #5
Member #154
Platinum Member
 
Indy's Avatar
 
Join Date: Oct 2000
Location: SW CT & Long Island Sound
My Boats: Missing my PowerPlay
Posts: 6,756
Default

I have 75+ hours on it so far, not a single complaint. Runs strong and is VERY easy to perform most routine service tasks. I haven't had to replace the impeller yet, but I only have a single so it shouldn't be much of a problem (I hope). My only regret is that I don't have a 540
Indy is offline  
Reply With Quote
Old 07-15-2002, 01:10 PM
  #6
Registered
 
Join Date: Nov 2001
My Boats: Spectre Sportfish Tournament Edition
Posts: 1,227
Default

Love mine now. Read this link for a history on my "out of the box" new engine problem last winter. It has since been resolved and my sentiments are with my other OSO 496 pals. They are strong performing and great to have in the boat!

http://www.offshoreonly.com/forum/sh...threadid=17040

Dave
Vyper340 is offline  
Reply With Quote
Reply

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gcoutlaw
Sonic
4
10-15-2007 05:57 PM
dmann
General Boating Discussion
0
01-02-2004 10:53 PM
patrick22309
General Q & A
9
09-09-2003 01:48 PM
fmi
Formula
0
08-05-2003 07:18 PM
boatinbill
General Q & A
6
07-15-2002 11:31 AM



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:30 PM.


Copyright 2011 OffShoreOnly. All rights reserved.