Go Back  Offshoreonly.com > General Discussion > General Boating Discussion
boat keeps stalling after running for awhile, fuel pumps??? >

boat keeps stalling after running for awhile, fuel pumps???

Notices

boat keeps stalling after running for awhile, fuel pumps???

Old 06-05-2016, 06:49 PM
  #1  
Registered
VIP Member
Thread Starter
 
Join Date: Jun 2016
Location: LaPorte, TX
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
Default boat keeps stalling after running for awhile, fuel pumps???

hello everyone, I have a 496 mag ho with gen 3 cool fuel system. here lately, after running for 30 to 45 minutes, the motor just instantly stalls, then comes back on, then stalls and finally shutting down.
took it to a shop and he found loose wires under the dash, took care of that but it didn't fix problem. the motor is year model 2005. does this sound like my fuel pumps are going bad? thanks for any advice.
rocky z is offline  
Old 06-06-2016, 12:22 AM
  #2  
Registered
 
Join Date: Feb 2013
Posts: 1,319
Received 308 Likes on 188 Posts
Default

Fuel tank vent plugged?
zz28zz is offline  
Old 06-06-2016, 03:47 AM
  #3  
Registered
VIP Member
Thread Starter
 
Join Date: Jun 2016
Location: LaPorte, TX
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
Default

i will certainly check that out today, thank you
rocky z is offline  
Old 10-10-2016, 05:12 AM
  #4  
Registered
VIP Member
Thread Starter
 
Join Date: Jun 2016
Location: LaPorte, TX
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
Default

forgot to reply, it was fuel pumps, replaced all of it
rocky z is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.